I'm trying to create a building, using the line segment tool. So I first created this big shape and then slashed through it with white lines. However on a colored background I want the lines to be transparent. When I try to do this, they of course completely disappear. Any advice on how to do this?


  • Hi Bianca, welcome to GDSE, I edit your question to leave only one, to get answers from the next point create another question please.
    – user120647
    Aug 28, 2018 at 8:53
  • If everything disappears when making a transparency mask, uncheck the "clip" option.
    – Billy Kerr
    Aug 28, 2018 at 9:31

2 Answers 2


From the Transparency Panel > make a Transparency Mask

  • Select the paths
  • Menu Edit > Copy
  • Menu Edit > Paste in Front
  • Fill = None
  • Stroke = 100% Black
  • Menu Edit > Cut
  • Select the shapes and Group them
  • Transparency Panel > Make
  • Uncheck Clip
  • Click the Mask Area, the right square at the panel
  • Menu Edit > Paste in Front
  • Stroke= increase the width
  • Click the Editing Area, the left square at the panel

enter image description here

  • Its easier, but also mor productive, to use knockout than transprency mask IMHO
    – joojaa
    Aug 28, 2018 at 10:24
  1. Select the lines and the shape.
  2. Go to pathfinder - divide.
  3. Go to the appearance panel, select the shape by doubleclicking on it.
  4. The heading in the appearance panel should now be 'path'.
  5. If the heading is 'group', you have to first select only one half of the shape.
  6. Put the opacity for the strokes on 0.
  7. At the bottom of the appearance panel, you'll find the general opacity.
  8. Open it, then click on knockout group until you see a checkmark.
  9. Now select the other half of the shape and do steps 6 to 8 again.
  10. Select the entire shape.
  11. Go to the stroke panel and increase the stroke weight.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.