In Photoshop, I've drawn a circle with fill set to 0% to get a circle without a fill. This looks fine in Photoshop, but when I save it as a PDF for use in another document, it fills the circle! What gives? How can I keep it without the fill when it's a PDF (the background is transparent).


  • You might want to include your PDF job options. – Scott Oct 31 '12 at 23:15
  • @deodorant I am unable to reproduce the error (CS5). The PDF I produce conserves transparency for the circle (emulating what you do, except from layers). If you flatten the layers first, will that help? – user7179 Oct 31 '12 at 23:25
  • Not sure what is meant by the PDF job options. Sorry, still new to photoshop :). Strange functionality though. I merged all of the layers into one layer and everything worked fine. – deodorant Nov 1 '12 at 4:34

you can try to select "Fill Pixels" option instead of "shape layers", then follow the same steps to draw your circle, make border and set the fill to 0%.

enter image description here


Another quick fix would be to create a new, empty layer, en merge it with the circle layer. This will Keep the effect, but without using the fill settings.

Another option is, close to what Rasha Amer said. Take your eclipse selection tool, make a selection as big as your circle, and right click. From the menu, select stroke, and change the settings for the desired effect.

Hope that helps you out ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.