0

My placed AI files get pixelated upon placing in InDesign. High Quality Display Settings change nothing about it.

The content of my AI is completely vector-based.

The jaggedness gets exported into PDF and PS-File as well, so this is not just a display problem that would not affect the end product.

**Jaggedness in InDesign, Using Placed Vector Content from Illustrator**

1

Whatever you do, this is a display problem. If the AI artwork is vector, whatever compression you use on the AI file or whatever display setting in ID, the final output — presumably a PDF saved from ID — should be vector and 100% sharp with no pixels. Compression and display settings do not turn vector into raster.

  • While I completely agree with you, it SHOULD NOT do that, the resulting PDF file - exported from InDesign - in fact DID get rastered. I opened the PDF in Illustrator and it consisted out of a set of triple-nested clip groups with images inside. At 36 PPI, no less, which makes them extra blocky. imgur.com/a/LwGCUdv Makeup of PDF-File imgur.com/a/f9xRijH Embedded Images – Ben Sep 24 '18 at 9:37
0

Ok, I have found the answer lies in the options used when saving the AI. It would seem that using the "Compress" option creates a kind of rasterized proxy and that is what you see in InDesign and what gets exported into the PDFs.

So, short answer, do not use Compression when placing the AI in InDesign. I will try to find out, where those options are and if you can change them.

Compress Option in Illustrator: On Compress Option in Illustrator: Off

  • Ok, I have found out why this unexplainable rastering occurs: If you save the AI file that is linked in your InDesign file, InDesign will use the Proxy Image it has stored for rendering that page. It will do that up until that point when you update that file's link in the link panel. If you export your file before doing that, the proxy image will get exported into the PDF. In a nutshell, compression is fine, just make sure you update your links in InDesign before exporting a PDF and if you want a smooth preview. – Ben Sep 24 '18 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.