3

This is similar to How do I disable or hide the pink background on missing fonts, but the problem is I actually have the font, which is KG Tangled Up In You.

When the font is used with default leading, it appears fine in InDesign. When I change the leading at all, the substitute font pink background appears.

I know nothing about font design, but does anyone know why InDesign thinks I'm using a substitute font when I change the leading? When I turn off the substitute font warning in 'Preferences → Composition' (I'm using CS5), the pink background goes away. When I change the leading back to its default, it also goes away.

2
  • Check if there is any grep style in the paragraph style.
    – user120647
    Sep 26 '18 at 19:01
  • @Danielillo, no grep style. Sep 26 '18 at 19:08
3

Cannot debug this without the actual files, but make sure you check this font is listed under 'Type → Find Font' before and after you change the leading. If there's a missing font error for any reason, you'll get a warning in this dialog box.

Then, if this is set up as a Paragraph Style or Character Style or a mix of both, a possible override is also likely to make it look like you are using this font when the style may actually be set up to use another font. Clear overrides, break the link to style or try anything that could clear any possible overrides.

I did just install this font on my system and I am not able to replicate the problem, the font seems to be working fine. 100% not a font problem.

2
  • 3
    Oh good grief. Somehow an Italic character style was imported with the document and became automatically assigned whenever I created a text block or converted the content of a shape to text. Since I was seeing what I expected, it never even crossed my mind that a character style was involved. Find Font pointed this out and deleting the unwanted character style made all my pain disappear. Thanks! (BTW, a friend of mine used to call this "PEBCAK" - problem exists between chair and keyboard...) Sep 26 '18 at 19:12
  • If you are a Mac user of old or work in a printers you will know that fonts can be the bane of your life at times - any insight is good. Unrelated to your solution but may be useful to others, if you have many fonts and use Font Explorer Pro to manage them (loads fonts as required by apps to keep cache memory efficient), it can sometimes glitch and fail to load a font / weight. Normally a quit of app / FEX will cure this. No idea why but its frustrating first time it happens, because you know you have the font. Failing that, put the font in /user/library/fonts so permanently ON. Sep 28 '18 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.