Does anyone know how I can draw a thin border around my Illustrator artboards where the border/stroke is equal on all sides after the export? What happens to me is if I have a 100px x 100px artboard, when exported it will be 1px on top, .5px on the sides and 1px on the bottom even though it is on the edge, set to inside and the correct dimensions.

  • Reading your question I guess there are banners of different widths, so the thickness of the border varies. Haven't you thought about leaving it without border and add a CSS border as it's explained here?
    – user120647
    Sep 27, 2018 at 15:37
  • I tested here (Illustrator CC 2015) and everything is fine.
    – LeoNas
    Sep 27, 2018 at 16:21
  • I can't reproduce the problem using the latest version of Illustrator CC 2018 (22.1).
    – Billy Kerr
    Sep 27, 2018 at 18:28
  • The banners are not for my website so I can't use CSS. And the dimensions here was just an example. I usually make 5 banners at once with different art board dimensions and every time an exact outline on the edges are never equal meaning they get cut off by half a pixel, etc.
    – Daniel
    Sep 28, 2018 at 16:13

1 Answer 1


It's possible that you had just created the banner/border with the incorrect size.

  • Try using Smart Guides (Ctrl+U)

  • Create the square by clicking and manually entering in the WxH value instead of Click+Drag to make it

When exporting you can untick the Clip to Artboard and that will export the image as far (or near) as the artwork spreads (but if it isn't a square, this may mess up your final project).

If you want to put a border around and clip to artboard, you just have to change the alignment of the stroke.

  • Open the stroke panel and choose from one of the Align Stroke options:

enter image description here

enter image description here

  • Thank you!!!! I really just needed to untick the clip to artboard and that all saved everything and kept the border inside. Perfect solution. Thanks.
    – Daniel
    Sep 28, 2018 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.