0

When importing a .txt file to InDesign as a linked file, is there a way to keep the formatting of the existing text frame?

I formatted a text frame with a object style (with only a paragraph style in it). When I import the .txt file into it, it doesn't respect the paragraph style.

I'd say that there isn't a straight and easy way, since I would have found it in the documentation. But it does say that:

"When you place a text or spreadsheet file, you can specify options to determine how the imported text is formatted"


PS: This thread is related but it only provides with a link which is dead…

  • Working with updateable text content is tricky, but then again I don't see any styling options when importing plain text files. And what's keeping you from just re-applying the style again manually after the import? – Lucian Oct 4 '18 at 12:13
  • Re-applying the style again is always possible, but it would add a few manual steps to the workflow… – CCR Oct 4 '18 at 12:32
  • That's part of the existing process more or less, unless your client can use InCopy to update content, which i assume is the end purpose. – Lucian Oct 4 '18 at 12:33
  • "RTF stands for Rich text format. Rich text files can contain text attributes such as bold, italics and different fonts and colored text. However, unlike TXT, RTF retains formatting, even if the file is opened in a different program than it was created in. TXT stands for plain text." Explanation – user120647 Oct 4 '18 at 12:42
1

I guess it depends on how you place your .txt file.

If you go File > Place and then click on your text frame, Indd will retain styles that were in use (paragraph and character styles).
Now, if you put your cursor into your frame and then File > Place, then everything should be OK.

Unless... Mind this tricky situation: if you select your text frame and click on a character style, Indd will kinda "apply" this character style to your frame.
So check that no character style is involved whatsoever.

Edit: Looks like I missed the part where the OP says that he wants to retain formatting when updating the .txt file.
I'm afraid this is not really possible.
Question is: does it have to be raw text files? Or could it be something else (rtf, doc(x), or even xls). If it has to be .txt files, I guess a small script that would remove all object style overrides could be easy to write...

|improve this answer|||||
  • Have you tested this? I can only make InDesign format the imported text with the Paragraph Style currently selected - not the Paragraph Style defined in the Object Style of the text frame which you place in. (I'm currently in CS6 which might be part of the problem) – Wolff Oct 4 '18 at 12:39
  • @Wolff Yes I have tested it. I'm also using CS6 on a PC... When you select the text frame, you should be able to see that the correct para style is now active in the para styles panel. Does it work that way for you? – Vinny Oct 4 '18 at 12:47
  • Yes, my Paragraph Style Panel acts like yours, but I'm getting inconsistent results when placing. It seems to depend how the text frame was initially made and which Styles are currently selected. – Wolff Oct 4 '18 at 13:05
  • @Wolff That's strange... I have made numerous tests and can't get any inconsistent result as long as cursor is placed into the frame and of course, para style isn't overridden. I wish I could see your tests ^^ Anyhow, this wouldn't resolve OP's request to be able to retain formatting. At this point, I think a script that would remove all object style overrides and the related para style would be the safest and fastest solution. Let's wait for his feedback... cheers – Vinny Oct 4 '18 at 13:20
  • Oh and... there is also the InCopy solution that the OP might want to dig in... – Vinny Oct 4 '18 at 13:22
0

When Placing

  • Check Show Import Options
  • At the options window, check Preserve Styles and Formatting from text and Tables

enter image description here

txt file

When Pasting

Menu Indesign > Preferences > Clipboard Handling > Check When Pasting...: All information...

enter image description here

|improve this answer|||||
  • 1
    I can't see how this helps. There is no pasting involved. The OP wants to place a .txt file which is per definition text only. When you place a .txt file in a text frame it seems that InDesign does not honor the Style, but you have to reapply it. – Wolff Oct 4 '18 at 12:19
  • @Wolff is right, I know about this function, but it doesn't solve my problem. The formatting I want to keep is in InDesign, and I'm importing, not pasting. – CCR Oct 4 '18 at 12:23
  • This looks like the Import Options for a .doc file. It looks different when placing .txt files. (At least on my InDesign CS6). – Wolff Oct 4 '18 at 12:26
  • As stated by @Wolff it is not the Import Options for .txt file which doesn't have all these options. – CCR Oct 4 '18 at 12:30
  • You are placing an .rtf file - not a .txt file. And the OP wants the unformatted text to be formatted with the Paragraph Style already in use in the text frame where the text is placed. – Wolff Oct 4 '18 at 12:35
0

I don't know if this helps you, but it seems that InDesign does honor your style settings if you:

  • Select the desired Paragraph Style.
  • Place the .txt file.
|improve this answer|||||
  • I just tried it but it doesn't seem to work. And it would be best if I could use the existing text frame as in the end, I will be updating the .txt file previously imported rather that reimporting one each time. – CCR Oct 4 '18 at 12:28
  • 1
    Oops you are right. It only works if you have the desired Paragraph Style selected. I have updated my (useless) answer. :-) – Wolff Oct 4 '18 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.