2

I have a symbol in sketch which I need to export. Whenever I make it exportable, it generates a large rectangular background to the symbol, which is not what I want. I want the symbol only as a png with no background.

I've never had this problem in the past, it usually just exports properly. I did, however, just upgrade to Sketch V.52, not sure if that has anything to do with it.

How do I get rid of the background? Thank you!!

The symbol I'm trying to export

How it looks when it's exported

2

Sketch 52 now include Artboard's background export options to all layers presents in the artboard.

You should disable "Include in export" background option in the Artboard containing your symbol in order to get rid of larger background in symbol export.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.