0

I've added a few light effects in Photoshop. When I export it i.e., save a .jpg or any other format all of the layer that have the light effects applied on are coming out full black. The effects aren't being rendered/exported in the output file. How do I render the image with the light effects applied? I can see the effect applied in the Photoshop file. But the output is black.

Screenshot of photoshop fileOutput file

  • 1
    You say light effects, but all I see is a group and a bunch of raster layers. Hard to say what is going on there. It seems like all of the elements coming out black are inside the group, which is unfortunately collapsed. If you are saving the document as it is in the first image, I have no reason to believe this should happen. Could be a bug... You could try to flatten the document before the export. – Joonas Oct 16 '18 at 9:34
  • I added the filter > Render > Lighting Effects to the "color balance" layer and the group which in the bottle. I tried flattening the document but again the result was all black. Also tried the Menu > Image > Duplicate option too. Same result. :( – Kaushik Oct 16 '18 at 9:53
  • I tried adding the photoshop file as a whole in Illustrator to see if i can do something there. But the file itself is getting imported with all the layers blacked out. – Kaushik Oct 16 '18 at 9:56
  • Merging the layers also resulting in the same. – Kaushik Oct 16 '18 at 9:58
  • If it's flattened, there's no way these very specific sections of the image change in any way on export. Did you try trashing preferences or just restarting PS? If you try restarting with and without trashing preferences, save a flattened version of the document and test that against the original document. The way it opens in AI could mean restarting won't help... It could also indicate that the file is corrupted somehow. There could still be a third reason, but I can't come up with anything else right now. — Can you dropbox link to the file? – Joonas Oct 16 '18 at 9:59
1

The same thing happen to me. I tried all the suggestions and nothing worked. Here is what you have to do. Before applying the Light effects. Convert the Layer into a Smart Object, that solves the issue!

Hope it helps

0

With the original file, try Menu Image > Duplicate > check Duplicate Merged Layers Only option > Ok

Use this new document to save it as a .jpg file.

0

Just make a group to all layers of which you need to export in JPEG.

You can achieve this by selecting all layers and using Ctrl+G to make a group. Then make a copy of this group by pressing Ctrl+J, then select and right click on the duplicated group layer and click Convert to Smart Object option.

Hide all layers except this layer. Now Export to Jpeg.

Your issue should be resolved.

0

CTRL+A to select the entire canvas, then go to Edit > Copy Merged. Paste that as a new layer in your PSD to quickly create a flat composite of all layers that should export without issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.