0

I have few layers in Photoshop, which I export using generator. They have similar output options

28 x 28 green-led@1x.png, 56 x 56 green-led@2x.png

only difference is file name. However, one of the layers have transparent areas around and being cropped. This is not what I want. I want it to be exported with transparent areas.

Is there any way to achieve it with generator?

enter image description here

Exported fine

enter image description here

Cropped

enter image description here

Expected

enter image description here

  • Any images to show of this? – Joonas Oct 17 '18 at 19:02
  • @Joonas updated – Michael Oct 17 '18 at 19:09
1

Since that layer doesn't have that low opacity area all the other ones have, you need to use a Layer Mask to define the bounds instead.

How can I get layers and groups that bleed off the canvas to appear as complete assets?

Set configuration options clip-all-images-to-document-bounds and clip-all-images-to-artboard-bounds to false via a Generator Config file. Assets that extend beyond the dimensions of the canvas will now be exported at their full size.

To selectively create an asset that is cropped to the canvas with the above options set, Select -> All then create a mask for the asset's layer or group. The bounds of the mask will be used to determine the output dimensions of the asset. Keep in mind that a group mask will not affect that group's children without the include-ancestor-masks option enabled.

  • Indeed, just adding white layer mask helped to export it without trimming. By the way, where the configuration file of generator is located? I was not able to find it via google, neither able to install configuration panel extension. – Michael Oct 17 '18 at 20:07
  • Right. It's a little hidden... You can change generator config with this free extension. Download adobe exchange link is right above the image. — I'm on the roll today. I didn't realize you mentioned the extension. I'm not aware of other ways to change the config. Then again I've never used asset generator too much... You can also install it more manually: adobeexchange.com/creativecloud/install-instructions.2274.html – Joonas Oct 17 '18 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.