1

I have 2 pages (that I've discovered so far) that do not have page numbers on them. I have already applied page numbering to the master pages, and all the other pages have page numbers. To show you this, I put the page numbers on a separate layer and hid all the other layers so the only thing you can see are the page numbers. I put the numbers on the bottom outside corners of each page. In the screenshot, on page 11 and 12, there are no page numbers, even though you can see them on the corners of the previous pages (you can't see the number but you can see something there, see red circles). I can't figure out why this happened and how to put the numbers back. The settings are already 'allow pages to shuffle', and the system knows its pages 11 and 12 but won't display the numbers.

In case it is relevant, I made the cover page i, and the first left hand page 1, and the right hand page 2 etc, so each left hand page is and odd number and each right hand page is an even number. Screenshot of Indesign page numbering

EDIT I have found the solution thanks to Lucian, it was to go to the master pages, right click and select "Apply Master to Page..". However, I wanted to add some more detail because 1) I want to know and 2) might be useful for others.

Anyone know how and why this happened? Does it happen to new pages you ad after applying master pages to all pages? Say I have 100 pages and I apply the master page layout. Then I decide to add 2 more. Will this happen again to the 2 new pages?

Also, I found this effect before I fixed the problem: Partial text overlap I was trying to add a watermark to all the pages by adding text to the master page when I found this on the 2 problematic pages. I put 2 lines of text on the master pages, on the top and bottom so it appears on each page. The screenshot shows the bottom text on the bottom half of the top page, and the top half of pages 11 and 12. It was very strange that only on those pages, part of the text has overlapping pages. Why is this? Do I have a second artboard or something I don't know about or can't see?

Note:This problem went away after I updated the "master page apply to" function, but would be nice to know why it happened.

Also the pages aren't blank, I just hid the layers to show the errors more clearly.

  • Is the same master page applied to these 2 pages? – mrserge Oct 25 '18 at 6:00
  • @ mrsege Yes It thought so. I re-applied the master pages to them as Lucian suggested, it worked, but not sure why and how it happened in the first place. – Stephanie Chen-Xu Oct 25 '18 at 6:19
  • Not sure what exactly, but it does sound like you're doing something wrong. First, you're using too many layers, which can get tricky, second, make sure your master is set up and applied in 'spreads' mode. If your master is a single page, that could also be a problem. – Lucian Oct 25 '18 at 6:46
  • I have 2 pages in my master pages, applied as a spread, the icon is 2 pages side by side, if that is what you mean. I also just discovered the overlapping thing is on multiple pages, Reapplying the masters page to all pages seemed to have fixed it but not sure if there will be more problems later. Is Indesign not designed to have layers? I have 5 layers. – Stephanie Chen-Xu Oct 25 '18 at 7:06
  • 1
    I have to disagree with the comment about the layers... 5 layers is pretty normal. Almost a minimum amount of layers. Of course, it all depends on what and how you're doing things. If each layer contains 1 object, then it's probably going overboard, but otherwise, I don't see anything wrong with that. – Joonas Oct 25 '18 at 7:11
0

Re-apply the master page to these pages, making sure there's no white objects on the actual pages where the page numbering goes. Any on-page artwork sits on top of master page introduced artwork.

Or, since these pages are blank, the cleaner option would be to just delete the pages and add 2 new pages using the existing master.

  • The pages are not blank. I only hid the layers to make the page numbers more visible. But, re-applying master pages to these pages worked, thanks! – Stephanie Chen-Xu Oct 25 '18 at 6:18
  • There's a number of things you can do on a page to remove page numbering, especially since you're using layers, so we can't really tell how or why that happened. But generally, re-applying the master will force all the master elements back on the page at any point. – Lucian Oct 25 '18 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.