2

I was trying to remove background from this gif in photoshop.

enter image description here

When I was done I saved it for web but my problem is that when playing the gif after saving, loads of white dots appear out of nowhere. Can I do something about that?

  • You could alternatively try this: graphicdesign.stackexchange.com/a/106302/2332 – Joonas Nov 4 '18 at 1:57
  • That gif is very funny. – Rafael Nov 4 '18 at 2:06
  • Thanks Joonas, i tried it. Those white dots dissapered, but it also deletes the white bunny -__ – Bleez Nov 4 '18 at 2:08
  • Yea, I don't think there's a way out of that one, given all the gaps in those frames before the fire. — Getting back to the original question. Is this gif the one with the issue after export? I'm on mobile right now so I have no idea. Are you sure the dots appears after export and it's not just something you missed? I might be able to figure this out if I was on desktop, but figured I'd ask anyways. – Joonas Nov 4 '18 at 2:24
  • I think I would've used After Effects. First key out the background much like how that online tool does it and then "refill" the white bunny background. That seems like the easiest method to me. – Joonas Nov 4 '18 at 2:37
1

The culprit is what I suspected in the comments. There are translucent pixels all around in various frames. Gif file format doesn't support that. Pixels are either fully opaque or fully transparent, so when you export that, it makes all of those seemingly nonexistent translucent pixels visible.

I checked this before the export by: giving the document a background, adding a Levels adjustment layer with blend mode difference to bring out any translucent pixel:

enter image description here

Luckily in this situation, you can get rid of the dots by adjusting Transparency Dithering when exporting.

In the "Safe for web" window, you need the following:

  • Transparency checkbox checked
  • Below that in the dropdown list: Diffusion transparency (probably any of the three would work in this case)
  • To the right from the previous dropdown list: Amount set to 0

Another major thing I noticed about in the psd file. Make sure to select all frames in the Timeline panel and right click the little bouncy ball icon on the bottom left of one of the frames and set frame disposal method as dispose. This will prevent frame overlapping.

With those changes the exported gif will be more like this one... Without the black background of course...

enter image description here

In your quest to remove the background, I guess, you left a bunch of white pixels surrounding the dark grey edge. You could try to get rid of it with Layer > Matting > Defringe..., but I'm not sure if it's worth it, because you'd have to do it to every layer and the end result might not be that much better.

  • Thank you Joonas very much for all your help. I really do appreciate it. That thing worked for me perfectly. Also I tried to edit every single layer with the defrindge thing by 1 pixel. It got way better as you can see here : dropbox.com/s/s95pbs46t0jd7ls/… but there is still little bit of white pixels left. Is there something left I can do about it to make it even smoother or is that it? Thanks once again – Bleez Nov 6 '18 at 5:01
  • @Bleez, I don't think there is much more you can do aside from like manual frame by frame masking or recoloring the white pixels at the edge. I don't really do animation in PS, so it could just be my limited thinking, but I feel like it would be even easier to just take the original and make better selections frame by frame. Would probably take less effort to track down the original creator of that and force them to export it without a background (or with a specific matte color). – Joonas Nov 6 '18 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.