0

I imported a figure from PDF (generated from Latex) into Inkscape as SVG for final editing. After import the raster-image does not fit the axis anymore.

This would not be an issue, but for some reason I cannot adjust the size of the raster image with free aspect ratio to fit it to the axis.

The lock in the toolbar (next to size and position) is not locked so it should be possible.

Furthermore for some reason the image is completely blurred (you should be able to see large individual pixels). Probably some filter, but I tried to remove a filters, which did nothing.

This is the image after import (I removed all other elements as this is for an as of yet unpublished article): Image after import

This is when trying to resize to a much smaller square aspect ratio (for illustration). Note how the box is squared, but the image maintains its aspect ratio. enter image description here

1
  • Click on the image to select it.
  • Open the XML editor.
  • Set the attribute preserveAspectRatio for the image to none
  • That was did the trick! Thank you so much, it was driving me crazy. Any idea how to remove the blur? I was about to post a separate question, but StackExchange only allows one question every 40 mins. – packoman Nov 4 '18 at 16:37
  • Yes. Select the image, right-click on it, select 'Object Properties' and set 'Image rendering' to 'optimizeSpeed'. This will make the tiny raster graphic look pixelized, instead of smoothed (because it's enlarged so much). – Moini Nov 5 '18 at 23:31
  • Note that this setting, when exported to pdf, may or may not be respected by the software that is used to display the pdf. – Moini Nov 5 '18 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.