0

When I rotate the object, it is having jagged lines. It was smooth before but I am suddenly facing this problem. The first image is the original one, 2nd one after rotating a bit.

original

jagged lines

  • 1
    Hi Narcissus, welcome to GD.SE, it's impossible to find out what the problem is if you do not put in the question or in the tags the program you use. – Danielillo Nov 13 '18 at 9:16
  • In Photoshop, I assume? Try different interpolation methods when tree transform is active. I'm guessing you might have nearest neighbor as the interpolation method. Also the biggest eyesore from what I can see is that black bleeding from under the green. That's all thanks to anti-aliasing. If you put the green block in a clipping mask with the black layer, that bleed-through won't happen. – Joonas Nov 13 '18 at 9:34
  • I used adobe illustrator. This problem is happening suddenly and I'm fairly new to using this software. @Danielillo – Narcissus Nov 13 '18 at 13:12
  • In illustrator. Looking at interpolation methods now. thanks for the reply. @Joonas – Narcissus Nov 13 '18 at 13:13
  • When I see some visual weirdness, the first thing I check is if GPU preview is on. You can see if it's on in the tab or window title. You can switch to CPU preview from: View > View using CPU. – Joonas Nov 13 '18 at 13:19
0

It seems like you have pixel preview mode on, Everything is shown like rasterized. Perfectly vertical and horizontal lines are still ok, but others are jagged.

Goto the View menu and uncheck Pixel Preview.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.