This question is asked here: How do I turn off anti-aliasing while drawing shapes in Photoshop?

And it has an answer from almost a decade ago. Photoshop has changed a lot then.

How do you do this in Photoshop CC?

  • I think, unless you are more specific, this is a duplicate of the question you liked to. I'd vote to close it as such, but that would close it immediately. Photoshop has really not changed in this respect. There's no global setting to enable/disable anti-aliasing in Photoshop. The nature of a pixel-based editor is to anti-alias. Other than using "Nearest Neighbor" when scaling, there's not really much there. – Scott Nov 15 '18 at 22:46

There's no antialiasing settings in Photoshop for shapes, but there's a trick suppressing the antialiasing in an action.

antialiasing action

Indexing a file

By transforming the RGB document into Indexed with the palette of your operating system you can use the Shape Tool without antialiasing.

Indexed doc

Setting a transparent color

An indexed document does not support layers, but transparency.

From the menu Image > Mode > Color Table, click on a random color holding Alt and this color will become transparent.

Select all and click Cmd + Delete Mac or Ctrl + Delete Win to make the document transparent. When creating a new shape this will be on a transparent background.

transparent background

Implementing the previous steps in a RGB document

From the menu Image > Mode > Color Table, save the custom palette with the transparent color.

Working from an RGB document, once the shape is made:

  • Convert the shape into a Smart Object
  • Double click to edit it
  • Convert it into an indexed file with the saved palette
  • Convert it back to a RGB file
  • Save and close to update it to the original RGB file

In this way you have the same shape without antialiasing. This process is a single click in an action.


Apply a Color Overlay effect to change the Smart Object color.

Color Overlay

| improve this answer | |
  • Great. A Threshold Layer in Lighter mode with a little lower threshold level does the trick also. – LeoNas Dec 16 '18 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.