16

I made quite some basic icons in Inkscape, but when displaying the SVGs in other tools (browser or basic Linux image viewer), The text parts are not displayed at all. How to get it to show up everywhere?

2

5 Answers 5

18

Aparently, the issue is that by selecting the text tool and then dragging a box instead of just clicking, one creates a free-flow text box instead of simple SVG text.

The solution is, to create a kind of exported copy of ones SVG, which has the free-flow converted to normal text, among maybe other changes. Make sure to keep a copy of the original free-flow SVG as well, for future modifications in Inkscape. Instructions from an excerpt from Wikimedia Text and Inkscape:

  1. While your text object is selected, go to Text -> Convert to Text. This converts your free-flow text object into normal text-objects. If you don't do this, then commons may display only black boxes were the text is.

  2. File > Save As... - make sure you choose plain SVG from the drop-down list, not Inkscape SVG!

3

A little late to the party, but I found that if you Print to File File → Print → Print to File, it works fine. This was on an Ubuntu machine, but this prevented me having to turn the text into un-editable objects.

1

I had a similar problem, I'd inserted some text, ajusted the character width and spacing between the letters to my needs, but I found the O and U letters that were (for some reason) slightly taller than the rest, so I split the text, resized the O and U and saved my project. When I imported the project into Sign Cut, the whole text was missing.

Solution

I cured it by going back into Inkscape, selecting each letter and using the 'Object to Path' option. Repeated this for each individual letter (it may work by selecting all at the same time but I didn't try that) and re-saved my project. Now in Sign Cut, all the letters appear correctly.

1
  • This also works, but then the text is converted to geometric objects, and can not be edited (or copied) as text anymore.
    – hoijui
    Jan 27, 2021 at 15:01
0

By saving to pdf (under the drop down menu in the file save menu), a box will then appear in Inkscape, which will ask things about fonts; don't change anything and press Ok. This is the only way that has worked for me so far.

2
  • 1
    Hi. Welcome to GDSE. Unfortunately the OP doesn't want a PDF, so that's not really going to help here. The question is about SVGs.
    – Billy Kerr
    Mar 21 at 13:47
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Mar 31 at 1:37
0

I encountered the same issue with symbols in Inkscape and managed to resolve this with the parts of two answers from other people on this page / mentioned above:

  • Select the object (either click the object itself or go to layers and select the object there)
  • Select menu option Path > Object to Path
  • Select menu option File > Save As... - make sure you choose plain SVG from the drop-down list, not Inkscape SVG

Open the newly saved image in another image viewer/browser and check if you now see the object/text.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.