0

I have a strange behavior, I'm using GIMP 2.10.8 on Ubuntu 18.10, Sorry I'm newbie.

  1. I copied one image and pasted to new layer.
  2. I changed the color using Colors -> Colorize
  3. I wanted to increase brightness so did the following Colors -> Brightness/Contrast increased Contrast to 70+
  4. Preview working fine, when I hit OK, it's not applying.

enter image description here

  • Hi. Welcome to GDSE. I've tried to repeat what you did, but it works as expected, and I can't replicate the problem you are experiencing. Can you check your image mode is in RGB mode, and not Indexed mode. It's the only thing I can think of. – Billy Kerr Jan 13 at 18:53
1

You can have such a problem if your layer has a partial opacity (ie, Alpha<100% on all pixels). When you apply Brightness-Contrast, you are viewing a fully opaque preview, but when you commit, alpha is restored and this dims the effect.

This could be a bug in Gimp 2.10

  • I agree. That seems to be the problem. I tried again to replicate the issue demonstrated by the OP, but this time I used an image with semi-transparent pixels. It would seem to be a preview issue/bug more than anything else, the filter still works. It just looks different when you commit. – Billy Kerr Jan 13 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.