0

I'm using cross-references within one document and want to display the page number of the linked content. I'm using it within a auto-sizing container (the selected object). But as soon as a page number is placed it adds the space on the right. When the text is aligned right, the space is on the left.

So my question is: Is there a way to control or remove the space, so that the number would act like a actual character?

enter image description here

  • I don't think we know enough about your setup to answer this. – Lucian Jan 15 at 15:10
  • "When the text is aligned right" - Which text? The page number, the body copy, or the other linked text? – 13ruce Jan 15 at 15:42
  • Check the tabs/indents on all of the text, including any paragraph styles as well as overrides. – 13ruce Jan 15 at 15:43
  • Check Object Styles too. Lots of things can affect this. – Lucian Jan 15 at 15:59
  • 1
    Looks like a job for cross-references to me. helpx.adobe.com/indesign/using/cross-references.html – Vinny Jan 15 at 16:24
0

Auto-sizing text frames is a brilliant concept, but sadly the implementation is buggy.

It seems that things aren't always updated in the correct order and sometimes the auto-sizing settings can get so self-contradicting that it forces InDesign to a total crash and leaves the document inaccessible. Especially if the auto-sizing text frames are anchored inside another text frame. This happened to me more than once.

I can't reproduce the exact issue you are experiencing, but I can force another error when I insert a cross-reference in an auto-sized text frame. The auto-sized text frames updates, but the containing text frame doesn't change:

As a hacky quick-fix I can recommend trying the following:

  1. Select the containing text frame.
  2. Press key up. (To force the text frame to update)
  3. Press key down. (To return the text frame to the correct position)

Sometimes this doesn't work, and you'll have to change the containing text frame even more to force a correct update:

  1. Select the containing text frame.
  2. Change the size of the containing text frame.
  3. Revert the containing text frame to its former size (don't just undo).

You can also try to force an update this way:

  1. Select the text paragraph containing the auto-sized text frame.
  2. Apply a different text alignment.
  3. Apply the correct text alignment.

Since I do believe that your issue is due to buggy behavior, it's hard to tell if any of these tricks will help. Maybe you need to manipulate the auto-sized text frame instead of the containing text frame?

You could probably achieve a similar, and much more robust, styling using either character shading (in newer version of InDesign) or a very thick character underline (in older versions of InDesign).

  • thanks for your tips! – I'm aware of the bugs where I need to force updating the text frame. But sadly this issue is only about the page number, cause the space is just there when I add it and no updating removes the space. And that's what I don't understand, why the page number object is adding this much space. – Malte Jan 17 at 11:15
  • Too bad it didn't work. One more thing you could try. It seems that the "box" containing the page number is taller than the available space in the auto sizing frame. Try changing the Text Frame Options for the auto-sizing frame: Set Inset Spacing > Top to 0, set Vertical Justification to Bottom, set Auto-Sizing to Width only and set the height manually. – Wolff Jan 17 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.