0

I'm trying to learn basic font design using Photoshop 2018 to design the font, Illustrator 2018 to convert the raster into a vector and then size my font accordingly, and then copy and paste into Fontlab Studio 5.

From everything I have been able to read on the various forums and tutorials the Vector font design I have just pasted into fontlab should now line up exactly with the guides I previously entered in Key Dimensions but it does not.

No matter what I do the pasted font design shows in the Fontlab glyph as 1000 pts high regardless of the size I set it to in Illustrator.

Using a capitol X as an example, The bottom is set on my baseline and aligned to the left of the artboard. The top right is set to the X Height guide which is set at 533 pts. The corresponding key dimensions within Fontlab are set exactly the same so they should match up exactly.

To copy my design from Illustrator into fontlab I select my design in illustrator and Ctrl + C (copy), go to Fontlab, open whatever glyph I wish to paste into and Ctrl + V (paste).

However when I copy and paste from Illustrator into the X glyph in Fontlab the font design is pasted as 1000 pts. No matter what settings I change or whatever I try the result is the same and I am just getting more and more frustrated so if anyone could point out what I am doing wrong I would be very grateful.

These are all of my settings.

I'm on Windows 7 64 bit

In Illustrator I have the following guides set:

Bassline = 0 pt

X Height = 533 pts

Capitol Height = 742 pts

D sender = -218 pts

A sender = 782 pts

Left & right zero is set to the left bottom pixel of the font design on the artboard.

Artboard Size 1000 pts.

I create my font character design and convert it to a vector with a black fill aligned to the left hand side of the artboard and transformed to the appropriate height.

In Fontlab 5 I open a new font file and make the following settings. File > Font Info > Metrics and Dimensions > Fonts UPM Size = 1000

File > Font Info > Metrics and Dimensions > Key Dimensions:

Bassline = 0 pt

X Height = 533 pts

Capitol Height = 742 pts

D sender = -218 pts

A sender = 782

0

3 Answers 3

0

A guessed workaround:

Try to insert a dummy line at altitude=1000 and remove it in Fontlab

If you do not want workarounds, save your file with "Save As" and import it. Select old enough format, maybe EPS or an old Ai file. I have no idea how old is needed nor is it even possible in newest Illustrator. A guess again: Try Ai8. I have seen it suggested in a few years old Fontlab discussion.

1
  • Sadly this did not make any difference Feb 8, 2019 at 16:10
0

I'm new to FontLab as well and used to have the same issue as this. But it might have to do with your Paste & Duplicate settings, maybe you didn't check the right box or that's what happened to me.

Try go to Edit > Preferences > Paste & Duplicate. In Keep Artwork Size, check [Place At Origin].

After you checked this, the options in the Fit Artwork will be left uncheck, checking one of these results issues like you posted.

Hope this helps, or if you already resolved this problem, I hope it helped those who needed them.

0

Most likely, based on the calculation of your values, it is scaling the glyph to fit. The previous answer is close, however in version 5 the verbiage and options are different from version 7. Additionally, there is a Windows bug you need to be aware of. Turn off scaling in FontLab 5 by going to: "Tools > Options...". Open "General Options". Click on "EPS and bitmap background". Uncheck "Fit EPS files to (Ascender - Descender) height".

The bug: On Windows, even after unchecking this, FontLab may continue to scale the glyph to fit. If so, you need to edit the Registry. Quit FontLab, run regedit, find HKEY_CURRENT_USER\Software\FontLab\Studio5\Options, then find value named EditScaleEPS. Change the value to 0. Won't ever happen again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.