-2

I found a duplicate post here but with no answers. I looked at this guide from adobe on how to feather edges hoping I'd find an answer but my Feather: option is already at 0 px. I have never had this issue before in photoshop or any other editor, but I also haven't touched any settings since the last time I used it so I have no clue what on to do. The photo, as you can clearly see, is pretty big but even so it shouldn't be coming out feathered. I even went to select -> modify -> feather and set the value to 0.1px but that didn't help.

Image from Gyazo

closed as off-topic by Scott, Ovaryraptor, WELZ, Westside, Lucian Feb 26 at 6:02

This question appears to be off-topic. The users who voted to close gave these specific reasons:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    You are zoomed in 400+% on what appears to be a very small, low resolution, image. Garbage in <> Garbage out. – Scott Feb 13 at 2:27
  • okay again, the image is big enough. It's 3840x2160. And also again, that shouldn't feather the edges. I opened it up in paint.net and it just cut out the pixels. In the cut command, pdn cut out the pixels. Mind blown. I just want photoshop to be able to cut out the pixels not add anti-aliasing and feathering and whatever. Further, clearly if I'm over 400% zoom and the photo still has good pixel definition the "grabage in" is not garbage. – Neywiny Feb 13 at 2:31
  • 1
    How are you making the initial selection? The gif tells us nothing useful. [btw, select -> modify -> feather is always going to add feathering, not reduce any existing.] – Tetsujin Feb 13 at 8:15
  • Uncheck the anti-alias option in the tool options along the top. Make your selection, then delete/cut the selection. – Billy Kerr Feb 13 at 11:21
  • Sorry for leaving that in there, I used the quick selection tool which doesn't even have that option. I was seeing if toggling it did anything and it doesn't. (Also, hardness is at 100% and if it means anything spacing is at 1%) – Neywiny Feb 13 at 14:29
1

The Marquee tools and the Lasso tools (as you are showing in your video) can be either aliased or anti-aliased.

Quick Selection Tool doesn't have an option to turn anti-aliasing off.

A quick workaround could be this:

  • Make your selection with Quick Selection Tool (or any other way).
  • Hit Q to enter Quick Mask Mode.
  • Apply Image > Adjustments > Threshold and just keep the Threshold Level at 128.
  • Hit Q again to leave Quick Mask Mode.

Now your selection is 1-bit with no anti-aliasing.

  • Yeah that seems like way too much work just to select something considering how often I used that tool in that project. I just went with a different program. Still a valid answer though. – Neywiny Feb 19 at 18:48
  • Ok. But why can't you just use Photoshop's Lasso Tool with anti-aliasing turned off? Which program did you switch to? – Wolff Feb 19 at 20:57
  • I needed something with edge detection, so I used gimp. Usually I use pdn when photoshop is being annoying, but I don't think I have an edge detection plugin. The best part, it has anti-aliasing and feathering options should I decide to use them but doesn't force me to. Amazing what free stuff can do. – Neywiny Feb 21 at 2:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.