2

I have found a font I really like to program with, but it is too tall.

I would like to scale the height of the font to 80% (or alternatively scale the width of the font to 125% if that might work better).

This is what I have tried:

  • Open the TTF file
  • Edit > Select > Select All
  • Element > Transformations > Transform
  • Scale Y to 80%, leave X at 100%

After doing this, it looks like it has worked: the glyphs in the editor now have the aspect ratio I want.

So I proceed:

  • Element > Font Info
  • Change the three font name fields
  • When recommended to "Change XUID?", accept
  • File > Generate Fonts to save a new TTF

But when I try to use the new font in an application (e.g. GVim or Konsole) it looks exactly like it did before!

What can I do to make the new aspect ratio stick?

  • Just to open a complete font in FontForge and scale it is a bit hacky and there could be 100 things you might be overlooking (and the font will look bad because the relation between the width of the horizontal and vertical stems will be ruined). That said, I tried to follow your steps and it seemed to work. I don't have the two applications you are mentioning. Are you 100% you are not using the old font by accident? How does the altered font look if you preview the font file? – Wolff Feb 23 at 15:13
  • Thanks for trying Wolff. That's interesting that it works for you. I am 100% sure I am using the newly named font. The only things I can think are: 1. The original aspect ratio is stored somewhere in the font file or glyphs, so the OS is scaling my shortened font back up again. Or 2. Some ID in the font has not changed, so the OS is still using the cached copy of the old font. – joeytwiddle Feb 25 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.