0

I've got a linked (from excel) table that will not format correctly.

These are my settings. enter image description here

Header and Table have been formatted in cell options which are linked to Paragraph styles.

The only thing that is happening is the Table cell style is being applied to the whole table. Left, Right Column and header are not changing to Header cell style.

I am bringing in the table, linked and have tried with and without formatting.

It doesn't seem to work.

What am I doing wrong?

0

InDesign won't arbitrarily decide what is a header or footer row. Sure, it would make sense if InDesign merely chose the first row of every table as a header. But, there are times where no header is desired, or where multiple rows are needed as a header. You must specify the number of rows to use as a header (or footer).

Table > Table Options > Headers and Footers

enter image description here

Then the number of rows you specify will have any paragraphs style configured in the General options applied to them.

CC2017 screenshot, but the method is the same in newer versions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.