1

I designed a multi-page booklet with three columns per page. In the master pages I defined one text box with a width of one column, and one text box with a width of two columns. The single-column text box is placed on the outside, i.e. the general layout looks like

I II II I

in a two-page view. When adding text afterwards, I use those pre-defined boxes by unlocking them and filling them with text. Now, when adding a new page before that, the pages are shifted, but the text stays at the same side, resulting in a layout like

I II I II
II I

while I would like to keep the layout to

I II II I
I II

Putting the boxes back to where they belong takes a lot of work, especially if multiple pages are added later during processing.
Thus, is there a way to tell InDesign to keep the layout, and flip positions, i.e. moving the single-column box to the outside again?

  • Can you add what had you tried and did you experiment with Liquid Layout? – SZCZERZO KŁY Mar 4 at 9:15
  • Due to limited knowledge in InDesign I was not able to try much, especially after the initial approach using master pages failed. Still, Liquid Layout looks interesting, I will take a look at that. – arc_lupus Mar 4 at 9:17
1

It's a good question. Indesign doesn't deal with "relative to spine" objects.

However it deals with relative to spine when it comes to: - paragraph styles - anchored objects (custom position)

So, you can use a workaround by anchoring your text frames inside another text frame.
Use object style > anchored object options in order to make your text frame relative to spine.

Here's an example of a Master-page where I created a text frame in which I anchored the two text frames:

enter image description here

Then I create an object style for narrow frame - that must stick to the outside and another one for the larger one.
In the Anchored object options, I set it as "custom", then checked "relative to spine". I also chose to align the frames on page margins. See settings below:

enter image description here enter image description here

Finally, copy the whole layout to the other Master page. You'll see straight away how the layout is now "kinda responsive"...

Bonus tips:
- Reduce the size of the "wrapper" frame in order to avoid as much as possible the risk of typing into it.
- Important : due to a long-standing bug (which might have been resolved now, I don't know, I use CS6), allow a small gap between the wrapper and the page edge. Otherwise, it might disappear when adding/removing pages.
- In the example below, I also set up the side text paragraph style as "relative to spine"

Hope that helps. Have fun :-)

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.