0

I created a TOC in Indesign, using paragraph styles. The TOC didn't fit in 1 frame, so I created another textframe (on the next page) and 'threaded' the TOC. The TOC now spreads over these 2 pages/frames as expected. However, the menu-option to update the TOC is greyed out.

My question: Is there a way to have a TOC continue from 1 textframe to another and still be able to update the TOC? I'm problably overlooking something very obvious..

I have been looking for some time now, there's a lot of info on TOC creation, but these TOC's always nicely fit on 1 page :)

many thanks!

  • 1
    Selecting one of the text frames, the update TOC menu option must be available. – user120647 Mar 4 '19 at 10:30
1

If you want to keep things automatic, just like adding pages to your TOC when needed and delete them if necessary after updating, you can use Smart text reflow feature.

Assuming you're document uses facing pages, you need to apply a Master to your TOC page with threaded frames.

In the preferences panel, check the Smart text reflow options. Turn on "delete blank pages"

See more about autoreflow here: https://helpx.adobe.com/indesign/using/threading-text.html#use_smart_text_reflow

See example below:

enter image description here

  • First of all, Vinny thank you so much for your time. I went through all of your steps, but it didn't work for me - well, not rightaway... It was one small cursor-detail in your explanation that did it: you clicked inside the 2-page-TOC to update, instead of selecting its frame. So: Having 1 frame with a TOC: by selecting this frame, Indesign lets you Update the TOC. Having 2 threaded frames with TOC: by selecting the frame(s) Indesign will not let you Update the TOC: now you have to 'double-click' and actually enter the TOC frame before you can Update. I'm not a regular Indesign user, – hjr Mar 4 '19 at 15:13
  • @hjr: I do believe the behavior is consistent. If you for example have one text frame with text, you can select it and format the text. If the text frame is a part of a thread, the formatting options are grayed out. – Wolff Mar 4 '19 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.