4

I created a design in Inkscape and I was having an issue with the design converting to PDF. The problem is whenever I export it to PDF, the blurred shadow disappears in the PDF file. I need this solved ASAP because I need it to send it for print. I hope you understand.

  • I can't replicate this problem. For me, blurring a shape works just fine when exporting as PDF. – Billy Kerr Mar 21 at 9:40
5

Inkscape's effects can suffer when you make a PDF. That depends on used PDF engine and settings. The same problem has occurred also with blending modes:

Inkscape does not export the layer's blend mode exclusion to PDF

As a first aid try to insert the shadow as separate object. Rasterize it. Edit > Make Bitmap Copy generates a rasterized copy. Set the rasterizing resolution high enough in the preferences.

  • Hey, I am newbie can you explain it a little? The design is really big and it has just small blurred shadow at the corners. – Syed Arsalan Mar 21 at 9:47
  • @SyedArsalan If the shadow is an effect, remove it. Draw dark shapes into the corners. Blur them. Make bitmap copies , remove the original drawn shadows. Be sure the blending mode in the objects panel is = normal for the new shadows. Test. – user287001 Mar 21 at 10:23
  • @user287001 - you don't need to make bitmap copies. Simple blurred shapes made in Inkscape work perfectly fine in a PDF exported by Inkscape. See example here. – Billy Kerr Mar 21 at 11:02
  • @BillyKerr the questioner got nothing. There's no evidence he didn't try what you suggest. I tried to write something waterproof which covers also the case he did as you suggested and got nothing. – user287001 Mar 21 at 12:03
  • @user287001 That's fair enough. Although it would have helped if the OP had mentioned exactly how the shadow was created in the first place, and like you I suspect it's probably some effect that is causing the problem. – Billy Kerr Mar 21 at 18:44
2

If you select 'rasterize filter effects' in the pdf export dialog, the filter effects will be carried over into the pdf file. I suspect that you accidentally unchecked that box (I believe it's checked by default).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.