1

Whatever I do, if I create an artboard in illustrator that is 540 x 540 pixels the artwork ends up being 2254x2254 when directly exported to png from Illustrator. I even just created a new AI file again at 540x540 pixels, then created a 540x540 filled box and aligned it perfectly on the artboard. Exported to PNG, bang its 2254c2254 again. Why is such a simple task so hard to achieve!?

  • 3
    What are your export settings? – Luciano Apr 1 at 15:21
1

It sounds like you are exporting at the wrong resolution (probably 300 PPI).

Try this:

  • Make sure to check Use Artboards to crop the PNG to the artboard:

  • Select 72 PPI to export at 1:1 scale:

  • Yes I figured out it must be a dpi related issue as dividing 300 by 72 then multiplying that by 540 gives the 2250 result I am getting. Thing is though, I want a 300dpi 540x540 output. I set my document to pixels and 300dpi then exported at 300dpi so why is it converting? Currently my solution is to open the AI file in photoshop and tell it to create a 540x540 300dpi png and it works but is very long winded. – Mr ED Apr 2 at 10:38
  • What confuses you is, that you are mixing concepts. I don't know why Illustrator is created like this, but it makes no sense to choose a resolution for a document which has its dimensions set in pixels. Resolution only makes sense when it comes to images with the dimensions set in physical units. Why do you need 300 ppi? It's just a "setting" - has nothing to do with the quality of the image. Setting the resolution to 300 ppi on a 540 x 540 pixels image signals that you want this image to be 1.8 x 1.8 inches (540 / 300) on print. – Wolff Apr 2 at 13:22
  • @Wolff Its set up this way because people really really wanted to be able to draw pixels. Now there are 2 ways to solve this, and this is technically easier and LESS confusing to people. In reality it makes no sense to have a pixel unit in a vector drawing application. – joojaa May 1 at 17:49
  • @MrED why would you export a vector image as a PNG for print? – joojaa May 1 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.