1

In Inkscape 0.92.4 (2019-01-14), I have some green lines. They all have the same contour properties:

Contour properties

But they result in a different displayed width:

Different displayed widths

Note that the last green line is thinner than the others.

I was able to reproduce the issue and I found out the following:

  • when I edit the line length using the path modification tool (F2), the line thickness remains as original
  • when I resize the line length using the selection tool (F1), the line thickness changes, although I have disabled all the scaling transformations (Disabled transformations for scaling). Interestingly, the lines become thicker when I make the lines shorter. The scaling transformations should do the opposite. This does not happen for a single line, but with multiple lines.

Here's an animation:

Animation of the issue repro

Given I didn't notice this change for a while and I have modified a lot of objects alread. I have to undo this "bug" now, how would I change the line thickness?

I have tried:

  • Setting the line thickness to something else, then setting it back to 0.5 mm.
  • How the green lines are made? When the wong thickness appeared? – user287001 Apr 16 at 11:17
  • @user287001: I've added an animation – Thomas Weller Apr 16 at 12:35
  • I have portable Inkscape 0.92.4 of the same day. The problem is non existent with lines which were just drawn with the pen, duplicated and placed with distribute. Do your lines have path effects? Are they clones or symbol instances? – user287001 Apr 16 at 12:50
  • @user287001: I'll check that. Perhaps I can also upload my file somewhere. Might be a problem of the original file. – Thomas Weller Apr 16 at 17:16
1

You seem to be scaling multiple objects. You could try not scaling them.

Instead use the Edit Paths by Nodes tool (F2) to select the lines you want to adjust, then Shift+click and drag to select the nodes you want to move, then CTRL+click and drag them up. Use a guide to help you get everything to line up.

Example:

enter image description here

Another method, if you still want to scale the objects but not the strokes, is to go into the Preferences > Behaviours > Transform tab, and uncheck the Scale Stroke Width option. Then you can scale without scaling the stroke width.

enter image description here

  • Now that I know the cause, I can of course do that. The problem is, I already scaled multiple objects and I'd like to correct the thickness of these – Thomas Weller Apr 16 at 17:14
  • Select one line which has the correct stroke thickness, click Edit > Copy (or Ctrl+C). Then select the other lines, and do Edit > Paste > Style (or Shift+Ctrl+V). – Billy Kerr Apr 16 at 17:16
  • Good suggestion. I'll try that when I'm back in the office tomorrow – Thomas Weller Apr 16 at 17:17
  • 1
    @ThomasWeller Sorry that should be Edit > Paste Style. It pastes the copied attributes (stroke and fill) to other objects. It's quite a useful feature. – Billy Kerr Apr 16 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.