2

I have a document that has a background I'm making in Photoshop, and a foreground I'm making in Inkscape. The document size is A1, 300dpi, which in pixels is 7016X9933.

I want to be able to move back and forth between the two applications, which means I want to keep the document sizes consistent.

Exporting a PNG from Inkscape and importing it to Photoshop is no problem. In the export dialogue you can set the pixel size and dpi, and everything is fine.

But, if I import a 7016X9933 document into Inkscape, even though my Inkscape document properties are set to be A1 size, the imported PNG comes out way over the page size. Apparently this is because Inkscape defaults to rendering everything in the interface at a print resolution of 90dpi.

This is a massive headache, because it means resizing the imported PNG at every time, and increases the odds of human error.

Is there any way I can make it so that Inkscape displays an imported 300dpi image within a 300dpi context?

  • Not with PNG. Photoshop does not actually embed the DPI value of the PNG inside the standard png data. But instead embeds a adobe special extension. TRy using a different format. Having a DPI seting for a vector file makes no sense. – joojaa Apr 25 at 15:25
3

Try this.

  1. Make sure the image in Photoshop is set to 300ppi.

  2. Do File > Save As, and choose PNG from the drop down.

  3. Open Inkscape, do File > Document properties, and in the Page tab set the page size, making sure to set the display units and custom size units to "px".

  4. In Inkscape, import the PNG using File > Import, choose the option to link the image.

When I try this, everything works as expected. The page fits the PNG.

  • This works for me without changing document units. In the import dialog, only make sure to 'take resolution from file' instead of using the standard import resolution. Do you have a png file that imports at the wrong size with that setting? – Moini Apr 25 at 21:45
  • The key seems to be to set the document size to 7016X9933 pixels in both Inkscapes document settings and export settings. But, in the export dialogue, set the dpi to 96. Any attempt to make the export settings work with 300dpi will throw off the page size. Photoshop doesn't care what Inkscape thinks the dpi is anyway. – Questioner Apr 26 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.