0

I had this problem a couple of times. I create a gradient overlay and I obviously want it to be applied to the visible part of what I'm doing. However it is applied to the 'uncropped' image so It might even not be visible at all, I have to spend some time moving the gradient around to be able to see it.

enter image description here

  • I don't get the description. You might want to add example images for what you are getting and what you want, if you're able to sort of fake it somehow... – Joonas Apr 26 at 19:11
1

You Have To Make Smart Object

Loook as I do; layer mask just hides the blacked area it doesn't erase it so if you want to really apply your style to your cropped area first make new Smart Object by copying masked layer and hiding their styles then just paste style on new smart object :) Hope it helps you out :)

Steps I did

=> ctrl+shift+n to create blank layer.

=>select mask by ctrl+click on mask and fill new layer by solid color ctrl/alt+backspace

=> deselect layer by ctrl+D

=>make clipping mask

=>apply layer styles

Hope you get what you wanting :)

enter image description here

  • Thanks for that but I don't want to erase it, I like keeping the original images in case I want to resize them while I'm working on it. Ideally I want a solution where I can choose to apply fx to mask area if that option exists – Taly Emmanuela Apr 26 at 12:06
  • got it ; wait updating it :) – Mr.Online Apr 26 at 12:09
  • Update my answer :) hope you get what you wanting – Mr.Online Apr 26 at 12:17
1

Invisible part won't be used for layer effects if you uncheck Transparency Shapes Layer in Layer Style Blending Options (double-click on a layer or RMB+click and select Layer Style...)

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.