1

I know what's the template layer in Adobe Illustrator and how it works. It's a great and perfect way to redraw a raster image in vector paths. But today I found out the template feature just works for raster images and objects, not vector ones! Today I received a vector file that objects were created in AutoCAD software, but some paths were not smooth as they created in AI and had a few minor issues that they needed to redraw in AI. So I imported the ai. document that objects (were created in AutoCAD) into AI's Layers Palette and then create a template layer for it and set the dim to 50%, but nothing happened to it and no opacity view for AutoCAD objects in the document appeared!

Why? Without making a template and create a dim and faint color for the AutoCAD objects, redraw the new AI paths are difficult. So I ignored the template feature and change the opacity of AutoCAD objects to 50 ~ 65 and lock the layer and finally create the anoter layer for the new path that I have to create AI paths and it worked and I finished the job. But I wonder why Adobe Illustrator doesn't make a template and dim view for vector paths that generated in AutoCAD or even Adobe Illustrator itself and just only work for raster images.

1

The option reads "Dim images". And it will only effect raster images. I can't explain why things are this way. But I do know that template layers have never altered the opacity of vector objects, only raster images. I can speculate that because AI is a vector drawing tool, it's somewhat assumed that you would not be using vector objects as a template which needs to be dimmed. Dimming is typical done to allow for easier trace overs, as I'm sure you know.

You can still use a template layer. If you want to reduce the opacity of the layer, simply use the Appearance Panel to lower the opacity.

  • Agree with you and the situation I faced with is rare, mostly we use a template for raster images to redraw, but I'd happy AI could do it without changing opacity feature manually. – Masoud Moghaddam May 28 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.