0

I have tried to make a Photoshop action of placing a watermark into some photos, without any coding, simply by recording the action. I have done this before and it worked, but I recently and suddenly, I got the "____ action could not be completed" so I deleted the action and made it again. Now it doesn't work.

The watermark consists of some text that goes along the bottom edge of the image and around the bottom right hand corner and up the right side, like a border around the bottom right hand corner. The background is transparent.

I wanted to add a watermark to images, and my actions consisted of:

  1. Placing either a photoshop file or a PNG version of the watermark into a file to be watermarked already open in Photoshop

  2. Watermark file is currently under 'transform' tool, so I press Enter to place the file. This is recorded as 'place'

  3. I move the file so it is in the correct location (aligned with bottom right hand corner) but this move action is not recorded. It used to be when I recorded a watermark action for a different watermark (that watermark file is the same as the current one, just a few letters different, and also no coding).
  4. Then I press Control + T and the watermark is in transform mode, and I resize it. This resizing is also not recorded.
  5. I press Enter to accept the new resized and moved watermark. This is recorded as "move to new layer".

The final result when I use that action is that the watermark is placed but not resized or relocated. This results in the watermark being so big, it falls off the canvas, and because the background of the watermark is transparent, absolutely nothing shows up in the image I wanted to watermark.

Here are the expanded recorded actions:

expanded recorded actions

Here are the results after I play the action in Photoshop, notice the outline of the watermark file:

Action result 1

In this screenshot, I have manually moved the watermark file to an area within the canvas so you can see the relative size of the watermark

Actual size of watermark that failed to resize

Edit:
I followed the suggestions made by Design Phoenix in the comments section and did it this way:
1) Place and embed the image, 2) resized it using 'transform' Control + T, 3) accepted it (pressing Enter) then moved it. (ie rather than placing image, resizing and moving then embeding it all at once) but it still makes absolutely no difference. Here is a screenshot after I made the action separately, you can see the steps in the action and the outline of the watermark. I resized AND moved it a lot despite it saying 1cm, I made it a lot smaller, at least 1/3 of the original size and moved it to the bottom right hand corner but it obviously does not register it that way. It used to work but now suddenly doesn't and I don't know what went wrong.

Revised action sequence

  • I don't see what this has to do with Windows 7 or any operating system. PS Actions have nothing to do with the operating system. Are you using CS5? Or was it only the Action itself that was created in CS5? Not sure I can remember if CS5 had this functionality, but in CS6 and CC you need to enable "Allow tool recording" in the Actions panel. – Billy Kerr May 31 at 13:54
  • As I mentioned in the title, yes I am using CS5, all done in CS5, and I added the computer operating system to avoid people asking for more machine specifications – Stephanie Chen-Xu Jun 1 at 5:33
  • @StephanieChen-Xu it is because your Place action is totally wrong!according to your actions step 2. it is only moving barely 1 cm and second movement is happening while you transforming it to 67% so that's where problem must be. my suggestion is to don't combine steps. for clean action; embed image. zoom it (dont move it so use shift alt) and then move it only. this will clean your action and please if it doesn't solve your problem using script might be best way :) – Mr.Online Jun 3 at 6:17
  • @DesignPhoenix I tried doing it step by step, see the update I added in the edits in the post. However, it made absolutely no difference and it still doesn't register that it was moved or resized at all, even though I resized it to at least 1/3 of the original size and moved it all the way to the bottom right hand corner. – Stephanie Chen-Xu Jun 6 at 13:06
  • @StephanieChen-Xu okay if action fails then script dives in! i can make a script for that :) just tell me your perfect need like 1. embed 2. transform to 35% 3. move it to 5 cm or so. just tell me proper steps and i'll make script for you :) – Mr.Online Jun 7 at 3:01
1

Thanks everyone, I have found the solution! I had to do each action separately and stop the recording after each action. Initially I did: Place the watermark, click and drag to move, control + t to transform size, then press enter to accept then stop recording.

The I was doing the actions separately but all in one recording session, ie place the watermark, press enter to accept, click and drag to move, control + t to transform size, accept, then stop recording.

What you need to do is:
Place the watermark, press enter to accept, stop the recording.
start recording in the same action again and do the next step: click and drag to move to the right position stop the recording.
Then press control + t to transform size, accept, then stop recording again.

  • Glad you found solution either this or that way XD – Mr.Online Jun 18 at 3:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.