If I run through an action with record on and in the following steps:

  • Start record
  • Print
  • Set 'Scale to fit media' to checked
  • Click the print button
  • Then configure the printer settings
  • Click print again on the printer popup window
  • End record
  • File > Automate > Batch > Select Currently open files and the recently created action.
  • Run

The action prints out a bunch of images that are printed way to big for the paper which means that the checkbox setting is not being recorded when I start my action.

This is what my image looks like My open photo in Photoshop

This is what the image looks like in the print dialogue box What the photo looks like in the print dialogue box

This is what I want the image to look like every time I play my action (with the checkbox inside the red box checked) enter image description here

Is there a way for me to make it so that it does record this element of the action?

2 Answers 2


Not that I know of.

I'd scale the image before printing to fit the media (make the scaling part of your action), then print. You can do the scaling at IMAGE > IMAGE SIZE...

  • While this workaround doesn't technically answer the question, it is probably the best way to go. Upvoting it.
    – 13ruce
    Commented Jul 11, 2019 at 12:06

I believe this is a printer preference, not a Photoshop preference. In order to set printer default options, you will need to open the printer's settings from outside of Photoshop (System Preferences) and set that check box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.