1

I wanted to start trying to make some pixel art characters. I tried 128x128 and even 16x16 image.

I have grid enabled and snap to grid enabled (even though the cursor doesn't appear to snap to the grid unless I hold shift which seems to be a line-tool)

Regardless of this, no matter what I do the pixel doesnt draw. If I change brush and size to 3 then I get a 'cross' consisting of 5 pixels.

Here is a screenshot of my problem, the cursor is not snapped and the settings are shown for the pencil, which will not draw

enter image description here

  • Uncheck "Lock brush to view" in the Tool options. – Billy Kerr Jul 10 at 17:41
  • @billykerr You should post that as an answer. And feel free to augment it with parts of my own. – xenoid Jul 10 at 19:31
4

To expand on @BillKerr comment, "Lock brush to view" scales the brush with the zoom: the ratio brush size/window area remains constant, so that at high zoom factors you don't get a brush that is bigger than your image window. In effect this shrinks the brush as you zoom in. If course if you start with a 3px brush, at 3800% zoom it is 3/38=0.1 pixel and is inoperative.

Further more, the 1. Pixel brush is "parametric". Gimp has two kinds of brushes:

  • "parametric" brushes (.vbr files), that are simple shapes defined by a few parameters: shape (circle/square/diamond), radius, and sides. These are the ones that you can edit with the brush editor. Under the hood they are close to vector graphics.
  • "bitmap" brushes, that are plain bitmap images (the z. Pepper brush, for instance)(.gbr files)

So, when you look closely, the 1. Pixel brush will always be at least 3px (one pixel for center, and 2x1 pixels due to radius=1. If you want a real 1-pixel brush, it has to be a bitmap brush. Gimp comes with such a brush, called Pixel (1x1 square).

  • A brush like this exists among the default brushes, only further down in the list. – Michael Schumacher Jul 10 at 22:33
  • @xenoid Sorry I was away when you left a comment, but anyway I don't think I could improve on your answer. – Billy Kerr Jul 10 at 22:37
  • @MichaelSchumacher OK fixed. – xenoid Jul 10 at 23:52
  • thank you for the help all. I didn't even notice or think about that option, maybe i clicked it by mistake or it was on by default. Thanks!! – Big T Larrity Jul 11 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.