1

How can I get rid of these dark lines in my pattern?

They only appear when I apply some sort of blend mode to my objects. These particular objects have multiply blend mode applied to them and the dark lines appear where the pattern "connects" in a grid.

I don't want to get rid of the blend mode, I need it for the desired look, but it's definitely the thing that causes the lines. Any advice?

pattern with dark lines

The swatch looks like this. It seems like an overlap to me too, but I created the box as a 6x6 square and duplicated objects by moving them by exactly 6 inches. Also in the Pattern tool I set 6 inches as the size of the tile. What's interesting is that when the Pattern tool shows me the preview of how the pattern will look, there is no overlap. Even when I set 9x9 preview so there are many repeats. It only shows later when the pattern is applied to a shape.

pattern tile

  • Could you post a screengrab of the pattern swatch itself - or drag it out of the patterns palette onto the artboard so we can examine the relationship between the pattern and its bounds? I ask because the simplest answer is that on those two sides there's a slight mismatch between the pattern bounding box and the actual pattern, and so you're getting literal overlap on those sides, hence those black lines. I might try redefining a new version of the pattern in which you intentionally make the pattern not fill the bounds, then gradually increase till they touch as a test. – GerardFalla Jul 26 at 14:52
  • If you output the file (web image art optimized or PDF) does the stitching still show? Sometimes it is merely an on-screen issue with anti-aliasing. – Scott Jul 26 at 16:32
  • @Scott yes, it still shows after exporting to any format, even PDF. I also have art optimized (supersampling) set as a default, so I don't believe that's an issue. – iluvilu Jul 26 at 17:33
  • 1
    It's probably due to anti-aliasing. What I'd suggest is that you flatten all transparency for the tile... select all the art and choose Edit > Flatten Transparency. This will alter the objects, So try it on a copy of the art first. If there is no transparency on the pattern tile itself, then this 1-2px anti-alias area won't be a problem. I can't say for certain this will work. I've honestly never used transparency in any pattern tile the way you are. – Scott Jul 26 at 18:10
  • 1
    @Scott thank you, the Flatten Transparency option worked! I didn't even know there's such a thing in Illustrator, thanks again! – iluvilu Jul 26 at 18:24
1

It's probably due to anti-aliasing.

What I'd suggest is that you flatten all transparency for the tile...

Select all the art and choose Edit > Flatten Transparency.

This will alter the objects. So try it on a copy of the art first.

If there is no transparency on the pattern tile itself, then this 1-2px anti-alias area shouldn't be a problem.

Disclaimer: I can't say for certain this will work. I've honestly never used transparency in any pattern tile the way you are using it.

  • I agree. What about applying transparency to the pattern afterwards. Like make totally nontransparent patter then apply transparency in the effects tab. Anyway the conflation error is a bitch when it comes to patterns. – joojaa Jul 26 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.