0

I am using Inkscape.

I have the following .svg file (here):

enter image description here

When I choose Save as copy and .pdf, I get the following (also in previous link):

enter image description here

I tried grouping, ungrouping and moving layers, the bottom left figure still does not appear. It is a .png figure, not vector, but that has worked in the past with our examples... Why does it not appear in the pdf?

  • 1
    Hi. Welcome to GDSE. What software are you using? What is the graphic that's disappearing? Vector? Raster? – Billy Kerr Jul 29 at 21:26
  • Sorry, I am such an idiot for not writing this in the question (edited one): Inkscape – SuperCiocia Jul 29 at 21:27
  • The XML is a total mess. Was this made in Inkscape??? I see clipping paths within clipping paths, clones, and groups - literally tons of crap in there. – Billy Kerr Jul 29 at 21:54
  • Sorry what's the XML? – SuperCiocia Jul 29 at 22:12
  • 1
    I think it was because the file had all those unnecessary clones and clipping paths, which just prevented it from working properly. As to how it happened, ultimately it depends on how the SVG was made. – Billy Kerr Jul 30 at 6:43
2

The complextity of the elements somehow seems to exceed limits of PostScript or PDF. If you save your SVG as Optimized SVG, you can reduce that complexity quite a bit.

While Inkscape still has the same problems with the optimized version, I used another app, Sketch to open it and export the PDF, and it seems to work fine.

PDF

1

I must admit analyzing SVGs properly, especially this one, is a little too complex for non-programmers. But do a workaround:

Make a bitmap copy of the problematic shape. It's in the Edit menu. Remove or close the original in the Objects panel.

You do not lose anything because it already seems to be rasterized, only wrapped in a complex way in the file structure and you said it's a PNG.

Be sure you have high enough resolution for bitmap creation, at least the same as your PNG would have in the final size or more. It's in the preferences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.