1

Even if only containing fully vectorized content, SVG files contain a resolution (in pixels). If saving as SVG from Illustrator (CS5), my Illustrator always sets this resolution to 72 dpi. That's what I mean with "native SVG resolution".

This is a problem with our Inkscape-based-lasercutter, that assumes 96 dpi. When I open the Illustrator-SVGs in Inkscape, all artworks are scaled down to 67%. A line that I create in Illustrator with 10 mm will only have 6.7 mm in Inkscape (and the lasercut).

Rescaling the whole artwork by factor 1.3333 will fix that problem, however I'm doing this OFTEN and it is tedious, so being able to rightaway save with 96 dpi would be much more convenient than reopening and rescaling before sending to the lasercutter.

Is there a way to change the "native/assumed" resolution (from the default of 72 dpi), when exporting from Illustrator (save as SVG)?

Unlike this thread here indicates, changing Effects > Document Raster Effects Settingshas no effect on my SVGs. My SVGs contain no raster-effects whatsoever, only paths.

  • Can you use eps? – joojaa Aug 28 at 14:05
  • 1
    What's the barrier to doing everything in Inkscape? – Moini Aug 29 at 12:01
  • SVG is designed for web display, not laser cutting. – Scott Sep 29 at 17:24
1

There isn't a way to change Illustrator's default 72ppi setting, as far as I'm aware.

The problem you are describing has been around for some time, and there are questions about it on the Adobe community site, but still no fix from Adobe. Adobe doesn't currently seem to care about SVG standards, and I wouldn't hold my breath waiting for a fix.

Here's my workaround for what it's worth, but I don't think it's really much quicker than what you are already doing.

  1. When you do Save as, check the option Use Artboard, hit Save, then when the SVG dialog appears uncheck the Responsive option, then hit OK.

enter image description here

  1. Open the SVG in a text editor, and manually change the document x, y, height, and width units from px to pt

enter image description here

  1. Save the edited SVG

Now it should be the correct size. I checked this by dragging an Illustrator created SVG into Inkscape.

1

No such way. There is no assumed dpi value just simplest interpretation. This is because you assume there is a unit called a pixel there is not. It just a arbitrary definition 1 internal unit equals to a pixel*. Since pixels aren't units there's no assumption that they have any size at all (trying to enforce such things is even worse). You shouldn't be designing with pixel sized units in mind at all.

On the other hand the fact that the SVG format does not have mm units option for export is a problem**. SVG is not really a very good format for manufacturing (this is one of the biggest sticking points). In fact ist not a good format for anything (its tolerable). But alas if you must you can make your own svg exporter.

Suggest you recompile your inkscape.

* no you can not get rid of the internal unit I mean if a company succeeds in definig a widely used custom unit it would be mad to let go of this particular feat. There's only a handful of companies that have succeed to do this so it actually is widespread used in modern times. /***

** were adobe to ever change this then it would be only in newest versions and it would newer be back ported.

*** Yes adobe is not standard complaint, CSS decided to make it 96 against among other things objections of Adobe. Adobe can not undo this. BTW Adobe lives in denial, adobe can not make a raster image that has NO dpi set. Yet 90% of modern image uses have exactly this property.

1

This may be a small consolation. Whilst I haven't found any easy method to have Illustrator and Inkscape utilise the same DPI system to transfer between each other with SVG's. I did however find that if I save the Illustrator files in their native .AI format, when opened in Inkscape they will be dimensionally accurate.

If someone finds a better solution where the SVG's can both utilise the same DPI, without having to manually resize or edit the SVG header then I'm willing to hear it too.

Hopefully in the meantime my suggested solution helps.

  • This is the same as using pdf as transfer format. Unfortunately for the size issue there will be no solution, until adobe changes their svg export (which probably wont happen, as adobe benefits form this situation) – joojaa Sep 29 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.