2

Ive got a multi page brochure which is mostly made up of jpeg photographs. On the last page Ive got some logos which are black and white PNG files (in an ideal world these would be vectors, but i only have them as PNGs, although they are nominally black and white, they are are not greyscale and actually CMYK).

When i export the PDF using the "high quality" preset the logos get compressed and can look blurry.

If i turn off the image compression the logos do not look blurey but the outputted PDF is hige as non of the other images are compressed.

As the logos are not greyscale i can not just turn off compression for greyscale images.

My current work around for this is to export the brochure pages 1-50, using the high quality pre set. Then export pages 51-52 (the logo pages) using the high quality preset without compression. I then combine these using acrobat.

Is there a simpler way i could do this so that the logos dont get compressed in the first place ?

Im running the latest version of inDesign CC on a mac 10.13.x

  • 1
    I do not think this is possible, at least not easily. Nothing regarding compression is aware of the content in any image. Merely it's color mode and format. If you can't target an image by either of these, then you can't target the image in any automated fashion. – Scott Sep 17 at 15:59
0

If the PNGs are grayscale (not just appear to be black and white, but actually grayscale gamut) then you can have InDesign not compress them on PDF export. In the Compression section of the PDF export, under the Grayscale Images settings, select "DO Not Downsample" and set Compression to "None."

Alternatively, if the logos are Black and White (meaning bitmap mode in Photoshop, with no shades between black and white) save them as tiffs with LZW compression (lossless), and replace in the layout. When you export, you can adjust the compression threshold to a resolution that is higher than the bitmap tiffs and it will skip them.

  • “although they are nominally black and white, they are are not greyscale and actually CMYK” – “As the logos are not greyscale i can not just turn off compression for greyscale images” – Janus Bahs Jacquet Sep 17 at 21:36
  • There is no way to exclude specific images from within the same gamut from compression. You will unfortunately have to convert the images to grayscale and relink in order to make it work. – 13ruce Sep 18 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.