0

I am getting a little frustrated with the newest version of Gimp because it is doing something that the older version has never done in regards to a transparent background.

In the old Gimp, when I copy and paste a layer with transparency (like a custom sprite sheet) to a image program that doesn't allow transparency by default like Paint or Sketchbook Pro, the background is a solid black color. There are easy solutions to this, and all are definately easier and quicker than what I have to do with the new Gimp.

Transparent pixels in the new Gimp now don't take one uniform color; instead, it takes what ever color it had before becoming transparent. This doesn't seem like a problem to programs like Gimp and Krita because they keep the alpha channels of the pasted layers; but, for sprite and other image editing programs that don't support alpha channels, whenever you paste a Gimp sprite layer onto these programs, instead of a uniform black or single-color background, you will get a flat image of both overlapping new and old work done to the pasted layer thus always leaving a messy image.

Is there somewhere in the Gimp settings that prevents transparent pixels from taking colors from the opaque pixels before it, and instead, have all transparent pixels keep to a single uniform color?

Edit:

Thanks for answering, everybody; but, how do you turn off this "non-destructive" erasing or "pixel data" option? I find it more of a hindrance than a benefit because I often use undo for erasing mistakes.

Kerr, though I haven't tested it yet, your solution seems to be the best for changing all transparent pixels back to one color. But, that is only a quick fix to a problem that will come back so long as that nuisance of a feature remains active.

I'm getting closer and closer to finding the solution, I just need that OFF switch!

  • The older version of Gimp I can remember downloading around 2014-2015 had the classic interface. Maybe it was a 2.8 and it had non-destructive erasing, but what I do remember vividly is I never used that feature and copying and pasting Gimp layers to other programs was never a problem. Maybe Gimp can add something to the next version that gives you the option to turn that feature off because I'm sorry, that feature is becoming very intrusive for me! Thanks again for everyone's responses: you guys actually helped me figure out the cause of the problem and gave me some good workarounds! – Temp Sep 28 '19 at 19:39
1

Gimp likely is not aware of the capabilities of the receiving end of the copy/paste so it copies what it has.

Easy work around:

  • Add a layer below your image
  • Fill with the default background you need
  • Edit>Copy visible
| improve this answer | |
0

A workaround:

This is ok if you can accept limited number of colors like in indexed mode. If you convert you image to indexed mode you can have only one kind of transparency which hasn't a slightest hint of the original color.

| improve this answer | |
0

Recent versions of GIMP have non-destructive erasing, to allow use of the anti erase function of the eraser tool. The eraser in GIMP basically edits the alpha channel without erasing the pixel data itself, but software such as MS Paint totally ignores the alpha channel when copying and pasting directly from GIMP.

To permanently delete the erased pixel data, you could create a new transparent layer under the layer with transparency, then merge the two layers. Obviously that will destroy the erased pixel data rendering the anti erase feature useless.

I checked this by copying and pasting into MS Paint, and it works.

Note: the method suggested by Xenoid may suit you better if you don't want to permanently erase the pixel data. Although even with my method you could simply undo the the merge to get the data back.

Edit: As far as I know, there's no way to switch off the non-destructive eraser functionality.

| improve this answer | |
  • The eraser doesn't erase to black on older versions, either. – Michael Schumacher Sep 28 '19 at 14:26
  • @MichaelSchumacher Yes, it was the OP that said it worked on older versions, but how old, I have no idea. I gave him the benefit of the doubt. The eraser certainly worked the same way in 2.8 as it does in 2.10. – Billy Kerr Sep 28 '19 at 16:49
  • It's likely not the erasing that has changed, but the copying or pasting - but it's not certain on what end. If the clipboard format used supports transparency and keeps the color values of transparent pixels, and if both the sending and receiving application use the same clipboard format, then the color values may be preserved. It could be the GIMP's copy support to the clipboard (or rather that support provided by GTK+) has improved to keep that intact. – Michael Schumacher Sep 30 '19 at 10:13
  • @MichaelSchumacher Hmmm . . . I seem to remember that older versions of Windows did not copy the alpha channel to the clip board when copying, so that might be the origin of the change in behaviour. – Billy Kerr Sep 30 '19 at 10:19
0

UPDATE:

I've tried using alternatives sprite-editing programs to remedy the issue I had with Gimp, but they all have one or two things that make still makes Gimp a superior choice: aside from Krita.

So based on what Michael said, I decided to test the recent version of both Gimp and Krita on a Windows 7 computer instead of the Windows 8.1 computer I often use. The same problem happens on Windows 7 on both programs: yes, Krita has the same non-destructive editing function that I have problems with.

I get that alot of people loves non-destructive editing: especially professional graphic designers. But for someone who likes to move sprites around constantly when making a spritesheet, it's becoming more and more of a hindrance.

As I was writing this, the only remedy I can think of to continue using Gimp for sprites is to make a second background layer with the preferred background color (black 0,0,0) and "copy merge" the sprites to other program. That was actually the first solution given to me by Xenoid, and I'm sorry that my cogs weren't clicking when first given that response. If, for some reason, that doesn't work, I will have to use Krita instead because while Krita has similar issues, Krita actually doesn't keep the invisible colors of a layer when "copy merging" no matter the background: including transparent backgrounds which Gimp cannot do. That's what was tested on my Windows 7 computer, let's see the same can be done on my 8.1 computer.

TL:DR: While I have found some workarounds, special thanks to you guys, it still would be fantastic for design programs with the non-destructive editing feature to have that feature be able to be turned on or off. The recent release of Gimp allows users to turn on or off the ability to edit hidden layers. Why can't the same be done for non-destructive editing?

| improve this answer | |
  • 3
    I'm getting lost here, are you answering your own original question or asking another? Can you edit to make it shorter and more to the point? Focus on the solution for Gimp to start. – Luciano Jan 17 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.