1

This question already has an answer here:

I have a 48*48 png file that I'm trying to scale up. Even though I converted it to a Smart Object, when I scale it up, Photoshop mixes the color of adjacent pixels to make more pixels for the transformed sized which is not what I want.

Here's a screenshot of the image: original

When I'm scaling it, the preview does not show mixed colors: preview

But when I hit enter, Photoshop mixes the colors: result

Which as you can see looks very blurry. How can I achieve the the second photo?

Basically I want to tell Photoshop to treat the layer as a Vector and not an Image.

Here's the original png file if you want to download: png file

marked as duplicate by Billy Kerr, joojaa, Wolff, GerardFalla, Luciano Oct 8 at 8:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    What you look for is a different interpolation method, Nearest Neighbor: here's a similar question: Resize an image without resampling?. Note that Smart Objects don't show the interpolation dropdown when scaling, to use a different interpolation method with those change the method in Photoshop Preferences. – Sergey Kritskiy Oct 2 at 14:42
3

After pressing Cmd + T Mac or Ctrl + T Win to activate the scaling frame, at the top options bar choose Nearest Neighbor and then do the scaling.

enter image description here

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.