I've been looking for a while and i haven't found an answer so far,

So i make a compound path of all the paths in "quentin" , and then convert it to a clipping mask in Layer 1.

Then i dragged the background from layer 2 that needs to be clipped in to Layer 1 and this happens...enter image description here
As you can see it only fills the little rounded corners of the first letter i want to clip... enter image description here Any ideas why? Thanks in advance

Weird thing is, it worked perfectly fine on my older try:

enter image description here

enter image description here

  • Looks like a graphics card glitch, try disabling GPU rendering. Also try releasing the clipping mask and re making it with everything you want to clip below the mask.
    – joojaa
    Oct 5, 2019 at 15:17
  • 3
    Is the type shape a compound path? If it is individual paths, then only teh top most shape will be used for clipping.
    – Scott
    Oct 5, 2019 at 16:22
  • On a new layer add your graphic. On the same layer add your type. Position your text where you want it over your graphic. Select your type and click shift-control(or command)-O to create oulines from your text. Next, with your outline selected, from the menu click Object/Compound Path/Make. Finally, select both, your text and graphic (making sure the text is above the graphic) and from the menu click Object/Clipping Mask/Make.
    – nocturns2
    Oct 5, 2019 at 19:50

3 Answers 3


I think your paths are not connected. If you double click on the path you can see the parts. You can connect them with selecting the endpoints and merge them with the "merge selected endpoints" tool. enter image description here

enter image description here

  • Sure, i changed the way i did to the way Billy advised to do it. Oct 5, 2019 at 16:52
  • Ah I see. The problem is that you can not use not connected paths as a clipping mask (as far as I know). You have to add a connection to every letter or apply a background for every letter, like you did in your test (I added a screenshot in my original answer) Oct 5, 2019 at 17:36
  • Can you take a single letter out of the clip group and try it? In your example the letter is still inside the group Oct 5, 2019 at 18:51
  • how do you mean? i did it on the 'q' and it created a clipping group consisting of the 'q', and the backgrounds (like my example screenshot) Oct 5, 2019 at 18:55
  • Found it! Your paths are not connected. If you double click on the path you can see the parts. You can connect them with selecting the endpoints and merge them with the "merge selected endpoints" tool. I post the pictures in the original post. Oct 5, 2019 at 19:52

The explanation of what you are doing seems a bit back to front, to be honest. Also there's no need to have anything on separate layers for it to work.

  1. If the background is vector, make sure all the elements which make up the background are grouped. If it's a raster image you don't need to do that.

  2. Make sure the clipping object is a closed compound path, and make sure it is on top of the background. If necessary move it to the front of the stack using Object > Arrange > Bring to front.

  3. Select both the background and object to be used as the clipping mask

  4. Click Object > Clipping Mask > Make

  • I did what you said, and achieved the same result unfortunately... Oct 5, 2019 at 16:38
  • Then something must be up with your compound path. I suspect it's not a closed path. It won't work with paths that are not closed. This probably has something to do with the way you have made the letter shapes, which you didn't share.
    – Billy Kerr
    Oct 5, 2019 at 23:46
  • Yeah, it became clear when i united them, so i mannualy joined the paths and it worked... I made the name in NX and traced it in AI, on first sight it looker good, but when i zoomed all the way in, it became clear the paths weren't connected, i thought using compound path (like everyone suggested) fixed the issue but only after using unite it became clear... Oct 6, 2019 at 8:55

After the question edit:::

You need as single compound shape of all the type characters.

Select all the outlined type and choose Object > Compound Path > Make from the menu.

Then, proceed to make your clipping mask.

  • Same result, that was actually the first way i did it... :/ Oct 5, 2019 at 17:47
  • It worked previously because you had 1 shape.. with all teh characters, you do NOT have 1 shape. You meed to make it one (compound) shape. If the menu item didn't work. Select the Character shapes and hit Pathfinder > Unite.
    – Scott
    Oct 5, 2019 at 19:06
  • When i unite them all something weird happens (maybe its because i unted all the compounded letters?) ill add a 4th screenshot for you Oct 5, 2019 at 19:09
  • nevermind it does the same thing when i unite them all after removing the compounds Oct 5, 2019 at 19:13
  • Sorry, this is unsolvable. There's something about your file which you aren't sharing -- and I realize it is probably because you are unaware of whatever the issue may actually be.
    – Scott
    Oct 5, 2019 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.