1

I recently updated my MacOS to Catalina, with that, Inkscape 0.92.2 using XQuartz or X11 stopped working. Since I use Inkscape to make all my figures for conference papers and things like that, I decided to download the new Inkscape 1.0 Beta for Mac which runs natively, and is much better overall. The only problem is that the LaTeX extension doesn't seem to work anymore and I need it to efficiently make figures. When I run the LaTeX extension, I get the following warning:

"Inkscape has received additional data from the script executed. The script did not return and error, but this may indicate the results will not be as expected."

The warning is this followed by this:

Traceback (most recent call last):
  File "pdflatex.py", line 75, in <module>
    LatexGenerate().run()
  File "/Applications/Inkscape.app/Contents/Resources/share/inkscape/extensions/inkex/base.py", line 111, in run
    self.save_raw(self.effect())
  File "/Applications/Inkscape.app/Contents/Resources/share/inkscape/extensions/inkex/extensions.py", line 155, in effect
    for child in fragment:
  File "pdflatex.py", line 53, in generate
    G=True, pdf_poppler=True, export_type="svg")
  File "/Applications/Inkscape.app/Contents/Resources/share/inkscape/extensions/inkex/command.py", line 190, in inkscape
    return call(INKSCAPE_EXECUTABLE_NAME, svg_file, *args, **kwargs)
  File "/Applications/Inkscape.app/Contents/Resources/share/inkscape/extensions/inkex/command.py", line 182, in call
    return _call(program, *args, **kwargs)
  File "/Applications/Inkscape.app/Contents/Resources/share/inkscape/extensions/inkex/command.py", line 172, in _call
    process.returncode, stderr, stdout, args))
inkex.command.ProgramRunError: Return Code: 1: b'Unknown option -G\n'
b''
args: ['/Applications/Inkscape.app/Contents/MacOS/inkscape', '--export-file=/var/folders/pf/sqqwth9x1zvghm1pz61mp1r80000gn/T/inktmp6stavbpk/output.svg', '--pdf-page=1', '-G', '--pdf-poppler', '--export-type=svg', '--without-gui', '/var/folders/pf/sqqwth9x1zvghm1pz61mp1r80000gn/T/inktmp6stavbpk/input.pdf']

And nothing happens. Is there any other extension that works with Inkscape 1.0 beta or is there some way to fix this so that I can use LaTeX in Inkscape again?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.