1

I have an issue with PNG FIles in Indesign and could not find an answer anywhere...maybe I am stupid. I placed various PNG Files with transparent background in INDESIGN = good. When I export as PDF and print it at home = all colours are as I want them to be = good. BUT: When I upload the pdf with my print company the Softproof shows everything converted to RGB (as the PNG File is RGB). Looks like PNG will not get converted to CMYK, instead the whole file will be converted to RGB. Any ideas?

  • 2
    Open Photoshop, change all the PNG files to PSD in CMYK mode, replace them in the InDesign document. – Danielillo Oct 11 at 16:58
  • 2
    PNG doesn't support CMYK. Home printers are designed to print RGB files, most can't print CMYK images. The same is not true for commercial print services, especially where spearations may be needed. They need CMYK images. Instead use a format that supports CMYK, such as TIFF, or PSD. – Billy Kerr Oct 11 at 16:58
  • Assuming they are processing your submission instead of simply sending you a copy of your own document: the softproof being RGB may be completely out of your control. – Yorik Oct 11 at 20:00
1

shows everything converted to RGB (as the PNG File is RGB). Looks like PNG will not get converted to CMYK, instead the whole file will be converted to RGB.

Two parts here.

  1. A raster image inside PNG is no more PNG or JPG or whatever... It is a raster image inside a PDF.

  2. The real problem here is that you are not using the correct PDF export setting.

A PDF is an export, let me make that clear, it is NOT the same indesign file you are working.

An export can potentially have several conversions done.

  • Fonts to paths
  • Transparency flattened
  • Resolution resampling and
  • Color modes changed... or not.

This is what you need to set, "Convert all color modes to CMYK".

Of course, you need to define color profiles in the first place.

  • 1
    I have set everything to High Quality Print and Standard PDF/X-1a:2001, Acrobat 4 (as requested) No Compression And Output: Conver to Destination (Preserve Numbers) and the ISO Coated v2 as desitnation. Before, of course, I have set the color profiles to ISO Coated v2 in EDIT/Color Settings and Assign Profiles... I thought I am smart :)) – Mika Oct 11 at 17:51
  • oh...and I have to add: if I pdf it without png file = all good...just with the png file = all not good...grrr – Mika Oct 11 at 19:06
0

If you want to make super sure, open up your PNG's in Photoshop, save each one as PSD in CMYK, relink the PSD's into the INDD file and export using the Press Quality PDF export preset.

  • I thought that is a great answer...at least the graphic showed up as CMYK color space and Document CMYK = great. But I have no clue why...as long as I choose PDF/X-1a:2001 it all looks wrong. Not if I do not include a PNG (if its RGB or not). Just the PDF/X-3:2002 looks like the working solution. Hmm...will print a version now... – Mika Oct 11 at 21:34
0

Ok, maybe I have got the solution. I have read a bit more about PDF/X and found that PDX-1a just allows CMYK. Thats what the printing company asked for...but looks like this is the issue as the PNG file is RGB. So I used PDF/X-3:2002 and that worked as it allows RGB too. Funny enough PDF/X-4 does not work...funny

  • That's funny. I was just recommending the PDF/X-4. Are you using the latest postscript driver for your printer? – 13ruce Oct 11 at 20:04
0

Try exporting the PDF using the PDF/X-4:2010 standard. If possible, use a postscript driver to print. If these two elements are in place, you may not need to convert the PNGs to CMYK at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.