1

When I draw paths in inkscape, I can use the mouse to drag handles and nodes around or I can use the XML editor to manually tweak the d= attribute of a <path> object.

However, if I edit the attribute and hit Ctrl+Enter or click the Set button, inkscape tries to "optimize" the path, this includes

  • removing white white-space / newlines that I use for visual orientation on longer paths
  • changing relative to absolute specifiers and vice versa (e.g. l to L)
  • changing specifiers all together (e.g. turning an l into a h)

It does a similar thing with transform values, where it always mangles sequences of scale / translate / rotate instructions into a matrix (which is equivalent, but less edit friendly for humans).

How do I tell inkscape to manually entered attributes alone.

  • There's a setting in the preferences that switches between relative and absolute coordinates (Edit > Preferences > Input / Output > SVG Output). The rest can only be kept if you don't use Inkscape for editing. I think for the matrix separation, there is an extension somewhere. So, do your drawing in Inkscape, and do your text editing in a text editor. – Moini Nov 7 '19 at 12:42
  • @Moini Yes, I actually just found the setting, too. It reduces the problem somewhat, but as you say, it doesn't address all problems. I use inkscape more to live-display a path while drawing it. I could change it in a proper editor and load up inkview or inkscape every time I touched it, but that strikes me as quite slow and unwieldy. – bitmask Nov 7 '19 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.