1

I'm trying to select a foreground object from a photo to remove the background using gimp 2.10.14. I am following these steps:

  1. rough outline of object using lasso tool
  2. press enter to enter foreground painting mode
  3. draw over foreground object
  4. enable 'preview' mode, looks good
  5. press 'select' button in floating window

But as soon as I press select the selection just becomes a load of vertical lines, see attached image

enter image description here

Just in case it isn't obvious the green wasn't part of the image! If I follow the same steps above but use the 'Matting Global' engine, then the selection is correct (although the results are not as good).

The settings I am using are:

r

EDIT - UPDATE

As per the comment from @user287001, I have attached another photo which is exhibiting the same issue.

enter image description here

The full-size image is located here: https://drive.google.com/open?id=1e0zWhsDJ0ot3MdSiUerLJEFajLp3P3_1

A gif showing the steps I am taking is here: https://drive.google.com/open?id=1-xdV0LWtw-PJsgixFrMlxNcAxRfnVumh You can see that the selection looks ok in preview mode, but as soon as I press select the selection is completely wrong

I am sure it is me doing something wrong, but if anyone has any pointers that would be great!

6
  • Sorry, but this is unsolvable without an exact copy of your photo. You should give one or you will get only guesses or nothing. In my GIMP 2.10 both engines work quite well.
    – user287001
    Nov 26 '19 at 10:44
  • Thanks @user287001 - yes, didn't want to share a private photo, but have now uploaded a new picture that shows the same issue. Also added a gif showing how I'm using the foreground select tool - it is more than possible I am doing something wrong!
    – Simon
    Nov 26 '19 at 19:04
  • 1
    Your GIF shows you operate ok except shapes and colorings this complex need bigger number of levels and the space between interior and exterior strokes should be less wide for good results. You have either corrupted installation, invalid graphics drivers or both. Update. reinstall GIMP. Have less load in your computer. Try to switch off hardware acceleration in preferences. In my 2010 purchased Win7 machine your tiger is extracted well. The decision process takes less than 1/3 the time in your GIF. Sorry for my inability to see more.
    – user287001
    Nov 26 '19 at 23:42
  • Thank you @user287001 - I increased the "levels" option to 5 and then it completes the preview much faster and also the selection is correct. I just couldn't understand why the preview looked fine, but the selection was so messed up. I will also try reinstalling, thanks. The PC is a high-end i7 with 32Gb, so should be fast! I appreciate your time and input
    – Simon
    Nov 27 '19 at 8:27
  • Insert your comment as an answer and accept it, because it solved the problem (my comment contained only guesses of the actual case). Otherwise this case stays as unsolved in the system.
    – user287001
    Nov 27 '19 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.