0

I need to use GIMP to generate a particular .pdf with a specific page size, namely, A1.

For this question, I did a minimal working example with A4 page size, since I believe the specific format doesn't matter.

I open GIMP, open the dialogue window for a new file, and I use the Template drop down menu to select A4 (300 ppi) and press enter.

If I do just that and export that new (blank A4) file to pdf, open said pdf and go see the properties, I'll see that the pdf's Page size is Portrait A4, with the correct dimensions (210x297 mm).

If I try to modify in any way the file before exporting to pdf, open said pdf and go see the properties, I'll see that the pdf's Page size is not A4, it's listed as Portrait Custom and the dimensions are way too big (875x1238 mm).

I don't see any options in the export to pdf dialogue option that allows me to get what I want (that is, a specific A4 pdf containing the image I desire).

Can someone help me ? Bellow are included the screenshot of my process :

Creating the new file :

enter image description here

The blank image I'm exporting :

enter image description here

The modified image I'm exporting :

enter image description here

The settings I used for both exports :

enter image description here

The properties for the blank PDF :

enter image description here

The properties for the modified PDF :

enter image description here

  • Hi. Welcome to GDSE. Unfortunately I can't replicate the problem, I just tried repeating your steps, but both PDFs are the same size in physical dimensions. – Billy Kerr Dec 2 at 16:37
  • @BillyKerr thanks. My initial try was on Manjaro KDE, after reading you comment, I tried on Windows 10 and it works. – JambonSama Dec 2 at 18:34
  • Yeah, I checked using Window 10, GIMP 2.10.12, checked PDF in Adobe Reader. All seems fine. – Billy Kerr Dec 2 at 18:41
1

Possibly a bug.

When I repeat your steps, in the image print size (Image>Print size) the print definition has been reset to 72PPI (and since the size in pixels hasn't changed, this gives the strange print size).

Forcing the print definition back to 300PPI seems to fix it for good (doesn't change with later exports or edits).

PS: made a bug report

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.