0

I'm working on a many-layered file (a vector of hundreds and hundreds of people), and I'd like to make some of them, but not all of them, non-Caucasian.

Each person is their own layer in the file.

I'm trying to change some people by locking specific layers, then running Edit / Edit Colors / Recolor. But the recolor command seems to ignore the layer locks, and recolours the whole file regardless of the locked layers.

Is there any way to force Recolor to "respect" the layer locks, or any other effective way to approach this?

  • Have you tried selecting the object/layers you want changed? This should be more reliable than locking layers. – Scott 2 days ago
  • That was the first thing I tried. Layer select greys out the "Recolor Artwork" option so it's not even an action I can attempt. – JeanSibelius 2 days ago
  • You must select the objects not the layers. – LeoNas 2 days ago
  • How are you selecting layers? Are you merely highlighting them in the Layers panel or are you clicking the little circle to the right of their name? – Scott 2 days ago
0

After locking the specific layers:

  • Double click the Magic Wand Tool, check Fill Color and set a tolerance number (12)
  • Click the skin color of a person
  • From the Color Panel, choose the HSB slider and change the color

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.