1

I wanted to apply a gaussian blur filter to just a recatngle area across a picture, so I duplicated the background layer, converted it for smart filters, used Filter -> Blur -> Gaussian Blur, then with the background checked I created a new rectangle shape layer and clipped the top blurred layer to the rectangle.

Everything worked as I expected up to this point but now I can't move the rectangle to see and compare how the effect looks in different areas of the image. Whenever I check it and try to use the Move tool the selection moves automatically to the top layer, the Rectangle stays in place and I just move the blurred layer. If I uncheck the visibility of the top layer I can move the Rectangle as usual, but with the top layer visible using the Move tool on the Rectangle automatically selects the top layer. What should I do to keep the Rectangle selected in order to move just the rectangle (i.e. the bottom layer of the clipping mask)?

enter image description here

2

You probably have the Auto-Select option turned on: this automatically selects the topmost visible layer. Disable the option in the top bar or hold Ctrl/Cmd while using the Move Tool to inverse its behaviour.

enter image description here

|improve this answer|||||
  • Works perfect, thanks a lot. – rp_photos Dec 17 '19 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.