0

Here are the steps I done:

  1. Opened PNG (not transparent)
  2. Selected white areas that I want to make transparent.
  3. Layers > Transparency > Add Alpha Channel
  4. Deleted selected areas (I see transparency in GIMP)
  5. Saved as .xcf file.
  6. Exported as PNG (tried various format settings)
  7. Reopen PNG in Gimp or other software --> Background is always white, no transparency.
  8. Added a transparent layer behind my main image.
  9. Re-exported as PNG.
  10. (Optionally) tried changing "Lock alpha channel" on both layers.
  11. Reopened PNG in Gimp or other software --> Background is now always black, no transparency.

How do I actually export a PNG with transparency from Gimp ?

  • Gimp normally exports a PNG with transparency. No need to lock the alpha channel or else. Is there an alpha channel in the reloaded PNG? What options did you use for export? automatic pixelformat (the default)? Something else (some of these other options do not support transparency). Is there an alpha channel in the reloaded PNG? Please update your question with the answers. – xenoid Jan 14 at 10:01
  • 4
    Does this answer your question? PNGs made in GIMP not coming out transparent – Bestorio Jan 14 at 10:07
  • @Bestorio Thanks, it was indeed Image > Mode > RGB that was set to another value. – TTT Jan 14 at 10:13
0

Solution found (thanks to Bestorio in comment) I needed to change "Image > Mode" to "RGB"

| improve this answer | |
  • Please use the edit link on your question to add additional information. The Post Answer button should be used only for complete answers to the question. - From Review – GerardFalla Jan 14 at 17:55
  • This is a complete answer. – TTT Jan 15 at 18:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.