4

I've tried multiple online tutorials, looked at several previously asked questions on here that I thought should have worked for me but for some reason I just cannot figure this out.

All I want is for the purple area to be gone/transparent/deleted, and the green area to remain. I've tried selecting both objects and clicking minus front in pathfinder, but I must be doing something wrong.

Also tried just making the inner circle transparent and filling in the area between the two shapes with live paint but when I tried that it removed the zig zag effect from the outer circle.

shapes I'm working with

1
  • If you truly want to do this with a effect then you must use knockout.
    – joojaa
    Jan 16 '20 at 5:09
4

You can do this using the Shape Builder Tool.

Select both of your paths, and activate the Shape Builder Tool (Shift+M).

Now, while holding down Alt simply click in the center shape.

This will subtract it from your shape.


You can see an example of this on this post.

1

First, make sure you aren't working in sublayers. Then you will need to "expand appearance" (from the Object menu) on objects with effects before you can use the pathfinder.

3
  • I was in fact working in sublayers so once I fixed that with release to layers I thought for sure it would fix the problem...but it didn't. So then I clicked on the object with effects (green) and clicked expand appearance, then tried selecting both again, hitting minus front, and still nothing.
    – Sara
    Jan 16 '20 at 23:34
  • Thanks for the response! Any other ideas??
    – Sara
    Jan 16 '20 at 23:35
  • Ungroup everything until you can select each element separately without using sublayers. Then use the pathfinder to unify each element separately. This can fix hidden geometry issues. With both shapes selected, use the Divide option from Pathfinder, then ungroup again and delete the circle.
    – 13ruce
    Jan 17 '20 at 12:53
1

If you want to retain the effect without expanding it, you could try this:

  1. Fill the inner circle black.

  2. Select both the circle and the shape which has the effect

  3. Open the Appearance panel

  4. Click on "Opacity"

  5. Click on "Make Mask"

  6. Uncheck "Clip"

Example

enter image description here

1
  • Thank you I did recently learn more about clipping masks which has helped a lot! I'll try this next time.
    – Sara
    Jan 19 '20 at 22:23
0

Minus Front is correct.

If it doesn't work, there must be something wrong with the actual shapes.

Make sure you're not clicking on the Minus Back: Minus Front should be the second icon from the top row.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.