0

I need to create renderings without anti-aliasing (i need to sample exactly and only pixel centers). For this reason, I deactivate the "Max subdivs" property of the Bucket image sampler and set Min subdivs to 1.

This works, however, I get a lot of salt-and-pepper noise on some materials.

Increasing the Min Shading rate doesn't seem to improve the situation. What can I do?

  • Nothing really. This is the nature of aliasing. You could offcourse make your own shader that does antialias on the shader level but not on sample level. – joojaa Jan 24 at 20:39
  • No, salt-and-pepper noise is not the nature of aliasing. – matthias_buehlmann Jan 25 at 11:03
  • Yes it is, this is a feature of how a raytracer works. The shaders that depend on futher raytracing results depned on jitter and multisampling these will not work if you turn off the antialiasing because its this antialiasing function that ensures they have enough random samples to provide a smooth result. Likewise many shaders themselves may not do antialiasing so they may also gain the same look and feel. Like I said you can deveop your own shaders that do multismpling independently of your primary sampling but most likely not all vanilla shaders can respond to this. – joojaa Jan 25 at 11:10
  • So by turning the antialiasing off you have inherited all the problems that were solved by adaptive sampling. Adaptive sampling is anitialiasing. – joojaa Jan 25 at 11:14
  • The salt and pepper pattern is caused by how the raytracer engine chooses to implement the pserudorandom generator so that it has a more optimal spread. This is also why the new gereation of raytracing noise killers dont work on real photographs just computer generated imagery. – joojaa Jan 25 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.