1

The pdf can be viewed in illustrator, but can't read as a pdf. The pdf is empty. Very weried.

I have upload the file here, you can see that the file is 155k, not empty, but when open using pdf reader, it is empty. please help.

The steps are easy, first I creat that pdf using mathematica.then i using Ai to creat an empty canvas, then I drag that pdf onto the canvas.

4
  • can you please also supply the linked file "chirality.pdf", there is nothing to look at in the illustrator file without it. – superluminal Jan 27 '20 at 14:07
  • @superluminal Thanks for mentioning that, I've uploaded the linked files too – an offer can't refuse Jan 27 '20 at 15:33
  • Interesting. From Acrobat, I can select the invisible object and make it visible by right-clicking it and selecting "Remove Crop". Not sure why it's coming it invisible though. Can you go through the steps you are using to create your PDF from Illustrator? – 13ruce Jan 27 '20 at 15:59
  • @13ruce I have update the steps. – an offer can't refuse Jan 28 '20 at 1:39
1

I've seen this happen often with SVG files from random sources opened in Illustrator.

There are Clipping Masks, upon Clipping Masks, upon Clipping Mask.. Eventually clipping everything.

enter image description here

I don't know how this file was constructed originally. However, releasing the masks (repeatedly) will show the artwork.

There's an inherent bug in Illustrator regarding some forms of clipping masks... but I don't know if it still exists in the latest CC release.

Essentially the bug is.. If you choose "Make Clipping Mask" from the Layers Panel menu you can only do that once per DOCUMENT. Not layer, not artboard, document. If you try and do this more than once, AI gets confused as to what should or should not be masked and hides everything.

You can try it for yourself...

  • create a file with 2 layers and some random artwork on each layer
  • draw a rectangle on Layer 1 and with it selected choose Make Clipping Mask from the Layers Panel Menu -- the mask should work
  • now draw a rectangle on layer 2 and choose Make Clipping Mask from the Layers Panel Menu -- All artwork on all layers will vanish (be completely masked).
  • Artboards do not matter. Layer order does not matter. In fact, construction as a whole does not matter as long as you stick to only one of the layer-based clipping masks per document the problem will not arise.

If a file is constructed elsewhere..... and contains more than one of these layer-based clipping masks.. the artwork disappears (or is masked entirely) in the same manner.

It's an odd bug, because only the Layer Panel clipping mask item is the cause. You can use the Object Menu or the Keyboard Shortcut to create as many clipping masks as you want and never hit the same issue. I'm not aware of why or how the Layer Panel Menu item is different than the Object Menu item.... but they are different in some manner.

Again I have no clue if Adobe has addressed this in newer versions of AI. I suspect they haven't since this particular bug has been around for, oh, 15 years, or there about. I know I logged it as a bug around CS1 or 2.. so.... yeah....

2
  • I am using Ai 2019 and the linked file is created from Mathematica. – an offer can't refuse Jan 28 '20 at 1:42
  • @anoffercan'trefuse It may simply be an issue with the PDF constructor from Mathematica and how it builds the clipping masks. I don't think it is inherently anything specific you may be doing or even any setting you could adjust. it's simply how some applications construct vector output and how Adobe apps read that output and then convert it to their own internal app specifications. It's easily removed/fixed with Illustrator. But for long documents, I can see how it would be very problematic. – Scott Jan 28 '20 at 2:11
0

I'm not exactly sure what's causing this issue - there's nothing about the PDF that would suggest any restrictions on linking or embedding any part of it.

I was able to get it to export correctly by embedding the PDF into the illustrator document, which you can do by selecting the PDF in the links panel, and then "Embed Image(s)" from the menu.

Links > Embed Images

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.